ca287f2044
In 0002-shared-libs-for-lua.patch, revision number is used to set library name: TO_SOLIB = liblua.so.$(R) However, library is built using PKG_VERSION which is passed only during build step: $(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $? As a result, dynamic library is not installed in staging or target paths since bump to lua 5.3.5 So, instead of replacing R by PKG_VERSION and passing this variable in all steps, simply update R to 5 Fixes: - http://autobuild.buildroot.net/results/28b6672188bb0082ac1467d3b45904880e3634f3 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Acked-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Fabrice Fontaine <<a href="mailto:fontaine.fabrice@gmail.com" target="_blank">fontaine.fabrice@gmail.com</a>><br></blockquote><div><br></div><div>Acked-by: Francois Perrad <<a href="mailto:francois.perrad@gadz.org" target="_blank">francois.perrad@gadz.org</a>></div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
32 lines
778 B
Diff
32 lines
778 B
Diff
Fix revision number
|
|
|
|
In 0002-shared-libs-for-lua.patch, revision number is used to set
|
|
library name:
|
|
TO_SOLIB = liblua.so.$(R)
|
|
|
|
However, library is built using PKG_VERSION which is passed only during
|
|
build step:
|
|
$(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
|
|
|
|
As a result, dynamic library is not installed in staging or target paths
|
|
since bump to lua 5.3.5
|
|
|
|
So, instead of replacing R by PKG_VERSION and passing this variable in
|
|
all steps, simply update R to 5
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
|
|
Index: b/Makefile
|
|
===================================================================
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -47,6 +47,6 @@
|
|
|
|
# Lua version and release.
|
|
V= 5.3
|
|
-R= $V.4
|
|
+R= $V.5
|
|
|
|
# Targets start here.
|
|
all: $(PLAT)
|