d2afa01f76
Update all appropriate version numbers as well as SHAs and MD5s as well as repbasing BR's patches on top of 3.6.1 codebase (new github repo tree, v3.6.1 tag was used). Note that patch: [PATCH] Change the install location of _sysconfigdata.py was dropped due to the fact taht build system now adds platform specific suffix to sysconfigdata's name, so each platform's file should have a unique name and distutils now allows to specify which sysconfigdata is used via _PYTHON_SYSCONFIGDATA_NAME see:c4b53afce4
92dec548ff
and patches: [PATCH] distutils/sysconfig: use sysconfigdata [PATCH] setup.py: do not add invalid header locations [PATCH] Do not harcode invalid path to ncursesw headers was dropped since it looks like it made it's way upstream, see:409482251b
1351c31aa9
e13c3201fb
respectively. Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
31 lines
918 B
Diff
31 lines
918 B
Diff
From 275db73c38e9b2135c774c475826fa077f8835c4 Mon Sep 17 00:00:00 2001
|
|
From: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
|
|
Date: Wed, 22 Feb 2017 17:55:59 -0800
|
|
Subject: [PATCH] Add an option to disable openssl support.
|
|
|
|
Signed-off-by: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
|
|
---
|
|
configure.ac | 6 ++++++
|
|
1 file changed, 6 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 3a12788..af12c09 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -3132,6 +3132,12 @@ AC_ARG_ENABLE(unicodedata,
|
|
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} unicodedata"
|
|
fi])
|
|
|
|
+AC_ARG_ENABLE(openssl,
|
|
+ AS_HELP_STRING([--disable-openssl], [disable openssl support]),
|
|
+ [ if test "$enableval" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} ssl _ssl _hashlib"
|
|
+ fi])
|
|
+
|
|
AC_SUBST(TK)
|
|
AC_ARG_ENABLE(tk,
|
|
AS_HELP_STRING([--disable-tk], [disable tk]),
|
|
--
|
|
2.9.3
|
|
|