f80e50d8a7
Ubuntu 16.10 has pie enable by default. This causes a build failure with syslinux. https://bugs.launchpad.net/ubuntu/+source/syslinux/+bug/1579023 Signed-off-by: Ryan Coe <bluemrp9@gmail.com> [Thomas: improve patch description.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
23 lines
529 B
Diff
23 lines
529 B
Diff
Description: Disable PIE to avoid FTBFS on amd64
|
|
Bug-Ubuntu: https://bugs.launchpad.net/bugs/1579023
|
|
Author: Graham Inggs <ginggs@ubuntu.com>
|
|
Last-Update: 2016-05-06
|
|
|
|
gcc 6.x has PIE support enabled by default, which causes a build issue
|
|
with syslinux. This patch disables PIE support in the relevant
|
|
syslinux Makefile.
|
|
|
|
Signed-off-by: Ryan Coe <bluemrp9@gmail.com>
|
|
|
|
--- a/gpxe/src/Makefile
|
|
+++ b/gpxe/src/Makefile
|
|
@@ -4,7 +4,7 @@
|
|
#
|
|
|
|
CLEANUP :=
|
|
-CFLAGS :=
|
|
+CFLAGS := -fno-PIE
|
|
ASFLAGS :=
|
|
LDFLAGS :=
|
|
MAKEDEPS := Makefile
|