18714011b2
Remove useless empty line. Update the patch and its name. We change from a release from Nov 2012 to a commit, because the project and there has been quite a number of commits since then. The patch will be sent upstream along with a request for a new release. Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
30 lines
855 B
Diff
30 lines
855 B
Diff
From 45ec86156819c0872d023b05001682a8d2d2dc25 Mon Sep 17 00:00:00 2001
|
|
From: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
|
|
Date: Sat, 6 Apr 2013 16:54:25 +0200
|
|
Subject: [PATCH] fix Qt4 package error in CMakeLists.txt
|
|
|
|
Avoid checking for uic executable by cmake as it results configure
|
|
time error if QtGui isn't installed.
|
|
|
|
Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
|
|
---
|
|
CMakeLists.txt | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index adb65e9..81854b1 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -52,7 +52,7 @@ IF (Qt5Core_FOUND)
|
|
ELSE()
|
|
MESSAGE ("Qt5 not found, searching for Qt4")
|
|
# Find Qt4
|
|
- FIND_PACKAGE( Qt4 REQUIRED )
|
|
+ FIND_PACKAGE( Qt4 COMPONENTS QtCore REQUIRED )
|
|
|
|
# Include the cmake file needed to use qt4
|
|
INCLUDE( ${QT_USE_FILE} )
|
|
--
|
|
2.1.1
|
|
|