3bc1746d27
cryptodev-linux fails to build when BR2_CCACHE=y. >>> cryptodev-linux 1.7 Building /usr/bin/make -j5 -C /home/dkehn/buildroot/output/build/cryptodev-linux-1.7 HOSTCC="/home/dkehn/buildroot/output/host/usr/bin/ccache /usr/bin/gcc" HOSTCFLAGS="" ARCH=arm INSTALL_MOD_PATH=/home/dkehn/buildroot/output/target CROSS_COMPILE="/home/dkehn/buildroot/output/host/usr/bin/ccache /home/dkehn/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-" DEPMOD=/home/dkehn/buildroot/output/host/sbin/depmod LOADADDR="0x82000000" KERNEL_DIR=/home/dkehn/buildroot/output/build/linux-2489c022b2932432606f897741a71b712e6dbe77 make -C /home/dkehn/buildroot/output/build/linux-2489c022b2932432606f897741a71b712e6dbe77 SUBDIRS=`pwd` ARCH=arm CROSS_COMPILE=/home/dkehn/buildroot/output/host/usr/bin/ccache /home/dkehn/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf- modules make[3]: warning: jobserver unavailable: using -j1. Add '+' to parent make rule. make[3]: /home/dkehn/buildroot/output/host/usr/bin/ccachegcc: Command not found Adding quotes around ${CROSS_COMPILE} KERNEL_MAKE_OPTS assignment in cryptodev-linux Makefile fixes compile error. [Thomas: add description and SoB inside the patch.] Signed-off-by: Doug Kehn <rdkehn@yahoo.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
21 lines
593 B
Diff
21 lines
593 B
Diff
Fix compilation with ccache enabled
|
|
|
|
When ccache is enabled the CROSS_COMPILE variable contains a space, so
|
|
it must be properly quoted.
|
|
|
|
Signed-off-by: Doug Kehn <rdkehn@yahoo.com>
|
|
|
|
Index: cryptodev-linux-1.7/Makefile
|
|
===================================================================
|
|
--- cryptodev-linux-1.7.orig/Makefile
|
|
+++ cryptodev-linux-1.7/Makefile
|
|
@@ -18,7 +18,7 @@ ifneq (${ARCH},)
|
|
KERNEL_MAKE_OPTS += ARCH=${ARCH}
|
|
endif
|
|
ifneq (${CROSS_COMPILE},)
|
|
-KERNEL_MAKE_OPTS += CROSS_COMPILE=${CROSS_COMPILE}
|
|
+KERNEL_MAKE_OPTS += CROSS_COMPILE="${CROSS_COMPILE}"
|
|
endif
|
|
|
|
build: version.h
|