c75e768d79
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
31 lines
1.2 KiB
Diff
31 lines
1.2 KiB
Diff
We need to be able to pass extra LIBS when our toolchain lacks NLS support,
|
|
this way we can build libintl and link to it.
|
|
A good example is uClibc with locale support disabled.
|
|
|
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
|
|
diff -Nura lshw-B.02.16.orig/src/gui/Makefile lshw-B.02.16/src/gui/Makefile
|
|
--- lshw-B.02.16.orig/src/gui/Makefile 2012-05-28 12:32:49.303885759 -0300
|
|
+++ lshw-B.02.16/src/gui/Makefile 2012-05-28 12:33:33.850206001 -0300
|
|
@@ -11,7 +11,7 @@
|
|
CXXFLAGS=-g -Wall $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS)
|
|
CFLAGS=$(CXXFLAGS) $(DEFINES)
|
|
GTKLIBS=$(shell pkg-config gtk+-2.0 gmodule-2.0 --libs)
|
|
-LIBS=-L../core -llshw -lresolv -lsqlite3 $(GTKLIBS)
|
|
+LIBS+=-L../core -llshw -lresolv -lsqlite3 $(GTKLIBS)
|
|
LDFLAGS=
|
|
ifneq ($(shell $(LD) --help 2| grep -- --as-needed), )
|
|
LDFLAGS+= -Wl,--as-needed
|
|
diff -Nura lshw-B.02.16.orig/src/Makefile lshw-B.02.16/src/Makefile
|
|
--- lshw-B.02.16.orig/src/Makefile 2012-05-28 12:32:49.292885680 -0300
|
|
+++ lshw-B.02.16/src/Makefile 2012-05-28 12:33:24.530139060 -0300
|
|
@@ -30,7 +30,7 @@
|
|
LDFLAGS+= -Wl,--as-needed
|
|
endif
|
|
LDSTATIC=-static
|
|
-LIBS=-llshw -lresolv
|
|
+LIBS+=-llshw -lresolv
|
|
ifeq ($(SQLITE), 1)
|
|
LIBS+= $(shell pkg-config --libs sqlite3)
|
|
endif
|