6335ff0857
Netopeer2 is a set of tools implementing network configuration tools based on the NETCONF Protocol. Netopeer2 needs libnetconf2 to have SSL/TSL and SSH support, so we enable both openssl and libssh+server from netopeer2, so that libnetconf2 has appropriate support. But netopeer2 does not use either, so does not build-depend on them. Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com> [yann.morin.1998@free.fr: - fix dependencies and their comments - explain openssl and libssh+server dependencies - fix codestyle in Config,in, noticed by Adam - fix codestyle in .mk ] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
34 lines
975 B
Diff
34 lines
975 B
Diff
From c6afffafd1e27054ff59b82ffed3a99795814631 Mon Sep 17 00:00:00 2001
|
|
From: Heiko Thiery <heiko.thiery@gmail.com>
|
|
Date: Mon, 8 Jun 2020 09:47:58 +0200
|
|
Subject: [PATCH] build BUGFIX take DESTDIR into account (#649)
|
|
|
|
When installing yang modules add DESTDIR prefix to the NP2_MODULE_DIR.
|
|
|
|
Fixes #648
|
|
|
|
Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
|
|
[patch taken from upstream:
|
|
https://github.com/CESNET/netopeer2/commit/726b1384a3f93090ede1143da86c99d5d24d06c5]
|
|
Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
|
|
---
|
|
scripts/setup.sh | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/scripts/setup.sh b/scripts/setup.sh
|
|
index 7175bc4..81abf63 100755
|
|
--- a/scripts/setup.sh
|
|
+++ b/scripts/setup.sh
|
|
@@ -8,7 +8,7 @@ fi
|
|
|
|
# avoid problems with sudo path
|
|
SYSREPOCTL=`su -c "which sysrepoctl" $USER`
|
|
-MODDIR=${NP2_MODULE_DIR}
|
|
+MODDIR=${DESTDIR}${NP2_MODULE_DIR}
|
|
PERMS=${NP2_MODULE_PERMS}
|
|
OWNER=${NP2_MODULE_OWNER}
|
|
GROUP=${NP2_MODULE_GROUP}
|
|
--
|
|
2.20.1
|
|
|