35d46ba365
There are new dependencies: erlang-p1-jiffy, erlang-p1-oauth2, erlang-p1-stun, erlang-p1-tls, erlang-p1-utils, erlang-p1-xmpp as well as two host dependencies on erlang-p1-utils and erlang-p1-xmpp. Otherwise the compilation via rebar fails. 4 patches have been refreshed and a new patch have been introduced to tell rebar to use host dependencies instead of trying to download them. Hopefully this patch could be drop in ejabberd 17.06. Missing SoB in patches have been added as well. Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
30 lines
821 B
Diff
30 lines
821 B
Diff
From d43a65b112ec995a5ee52aca2a16e5cf9699d7c1 Mon Sep 17 00:00:00 2001
|
|
From: Johan Oudinet <johan.oudinet@gmail.com>
|
|
Date: Wed, 20 Jan 2016 08:16:26 -0500
|
|
Subject: [PATCH] disable ERLANG_DEPRECATED_CHECK
|
|
|
|
Without this patch, the configure will try to execute erlang to check
|
|
if it uses deprecated types. Assume the answer is false.
|
|
|
|
Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
|
|
---
|
|
configure.ac | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index cd1ab08..a4f1533 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -235,7 +235,7 @@ if test "$ENABLEUSER" != ""; then
|
|
AC_SUBST([INSTALLUSER], [$ENABLEUSER])
|
|
fi
|
|
|
|
-ERLANG_DEPRECATED_TYPES_CHECK
|
|
+AC_SUBST(erlang_deprecated_types, false)
|
|
|
|
if test "$sqlite" = "true"; then
|
|
AX_LIB_SQLITE3([3.6.19])
|
|
--
|
|
2.5.0
|
|
|