c7bfb68208
The strict unused-const-variable checking was causing autobuilder errors when trying to build Xen tools/libxl as the migrate_*[] arrays are not always accessed. To avoid the error edit the Makefile to stop all general warnings being treated as errors, by removing the -Werror flag. Fixes: http://autobuild.buildroot.net/results/0e0/0e0d4aa4a05da5804821951289c0a4049b009c61/ Signed-off-by: Alistair Francis <alistair.francis@xilinx.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
27 lines
784 B
Diff
27 lines
784 B
Diff
From 19f1e70041044fde1542109a0525424cc6d5d053 Mon Sep 17 00:00:00 2001
|
|
From: Alistair Francis <alistair.francis@xilinx.com>
|
|
Date: Wed, 7 Dec 2016 11:35:10 -0800
|
|
Subject: [PATCH] tools/libxl: Disable strict Werror checking
|
|
|
|
Signed-off-by: Alistair Francis <alistair.francis@xilinx.com>
|
|
---
|
|
tools/libxl/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/tools/libxl/Makefile b/tools/libxl/Makefile
|
|
index defeb40..239faf3 100644
|
|
--- a/tools/libxl/Makefile
|
|
+++ b/tools/libxl/Makefile
|
|
@@ -11,7 +11,7 @@ MINOR = 0
|
|
XLUMAJOR = 4.7
|
|
XLUMINOR = 0
|
|
|
|
-CFLAGS += -Werror -Wno-format-zero-length -Wmissing-declarations \
|
|
+CFLAGS += -Wno-format-zero-length -Wmissing-declarations \
|
|
-Wno-declaration-after-statement -Wformat-nonliteral
|
|
CFLAGS += -I. -fPIC
|
|
|
|
--
|
|
2.7.4
|
|
|