2b1bbbb7cc
The unversioned library was missing in the build system, part of the fix was backported from upstream, the final patch was sent upstream. Fixes linking against gpm by the links package which fails to detect gpm support when libgpm.so is not present. Configure log from links without this patch: checking for gpm.h... yes checking for Gpm_Open in -lgpm... no checking for Gpm_GetLibVersion... no Configure log from links with this patch: checking for gpm.h... yes checking for Gpm_Open in -lgpm... yes checking for Gpm_GetLibVersion... yes checking for Gpm_Event wdx and wdy... yes Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
32 lines
1.2 KiB
Diff
32 lines
1.2 KiB
Diff
From 445be05fba32c512fd87a0c98b4e9936629ef95e Mon Sep 17 00:00:00 2001
|
|
From: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
Date: Sat, 20 Feb 2016 17:59:52 +0100
|
|
Subject: [PATCH 1/1] src/Makefile.in: Really install unversioned solibrary
|
|
|
|
This commit is a follow-up to
|
|
https://github.com/telmich/gpm/commit/06b00d53d8bd513ad5d262dc94a016c6fbf2d3aa
|
|
which created libgpm.so but failed to include it in the install target.
|
|
|
|
Patch sent upstream: https://github.com/telmich/gpm/pull/11
|
|
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
---
|
|
src/Makefile.in | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/src/Makefile.in b/src/Makefile.in
|
|
index 7e9e2ef..bca226f 100644
|
|
--- a/src/Makefile.in
|
|
+++ b/src/Makefile.in
|
|
@@ -115,6 +115,7 @@ install: check
|
|
if test "x@SHLIB@" != "x" ; then \
|
|
$(INSTALL_DATA) -m 755 lib/libgpm.so.@abi_full@ $(libdir)/libgpm.so.@abi_full@ ; \
|
|
cd $(libdir) && $(LN_S) -f libgpm.so.@abi_full@ libgpm.so.@abi_lev@ ; \
|
|
+ cd $(libdir) && $(LN_S) -f libgpm.so.@abi_full@ libgpm.so ; \
|
|
echo "WARNING: We installed a lib, you should now call ldconfig" ; \
|
|
echo "f.i.: ldconfig -n -l $(libdir)/libgpm.so.@abi_full@" ; \
|
|
echo "Or to update everything just type ldconfig" ; \
|
|
--
|
|
2.7.0
|
|
|