kumquat-buildroot/package/htop/htop.mk
Francois Perrad cac0ab5478 package/htop: bump to version 3.0.1
Both patches are now upstream and can be dropped:

 - 7cfaa9dede0f7f711a0fb961559e9629e7c7a259 is "MakeHeader.py: Fix for
   non-utf8 environments"

 - dfd9279f87791e36a5212726781c31fbe7110361 is "Resolve complation
   issues with -fno-common (default from gcc-10)"

The license file hash is changed due to the removal of one empty line:

@@ -353,4 +353,3 @@
  applicable licenses of the version of PLPA used in your combined work,
  provided that you include the source code of such version of PLPA when
  and as the GNU GPL requires distribution of source code.
-

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2020-09-07 23:07:28 +02:00

29 lines
895 B
Makefile

################################################################################
#
# htop
#
################################################################################
HTOP_VERSION = 3.0.1
HTOP_SITE = https://dl.bintray.com/htop/source
HTOP_DEPENDENCIES = ncurses
# Prevent htop build system from searching the host paths
HTOP_CONF_ENV = HTOP_NCURSES_CONFIG_SCRIPT=$(STAGING_DIR)/usr/bin/$(NCURSES_CONFIG_SCRIPTS)
HTOP_LICENSE = GPL-2.0
HTOP_LICENSE_FILES = COPYING
ifeq ($(BR2_PACKAGE_NCURSES_WCHAR),y)
HTOP_CONF_OPTS += --enable-unicode
else
HTOP_CONF_OPTS += --disable-unicode
endif
# ARC uses an old uClibc that needs dladdr() for backtrace support,
# which doesn't work for static only scenario, so as a workaround, we
# pretend that execinfo.h is not available.
ifeq ($(BR2_arc)$(BR2_STATIC_LIBS),yy)
HTOP_CONF_ENV += ac_cv_header_execinfo_h=no
endif
$(eval $(autotools-package))