6f8a717e8e
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
46 lines
2.0 KiB
Diff
46 lines
2.0 KiB
Diff
--- linux-2.6.28/arch/cris/Makefile 2008-12-25 00:26:37.000000000 +0100
|
|
+++ linux-2.6.28.my/arch/cris/Makefile 2009-01-12 13:21:44.000000000 +0100
|
|
@@ -40,7 +40,7 @@
|
|
|
|
LD = $(CROSS_COMPILE)ld -mcrislinux
|
|
|
|
-OBJCOPYFLAGS := -O binary -R .note -R .comment -S
|
|
+OBJCOPYFLAGS := -O binary -R .note -R .note.gnu.build-id -R .comment
|
|
|
|
CPPFLAGS_vmlinux.lds = -DDRAM_VIRTUAL_BASE=0x$(CONFIG_ETRAX_DRAM_VIRTUAL_BASE)
|
|
|
|
diff -urN linux-2.6.28/arch/cris/arch-v10/boot/Makefile linux-2.6.28.my/arch/cris/arch-v10/boot/Makefile
|
|
--- linux-2.6.28/arch/cris/arch-v10/boot/Makefile 2008-12-25 00:26:37.000000000 +0100
|
|
+++ linux-2.6.28.my/arch/cris/arch-v10/boot/Makefile 2009-01-12 13:28:25.000000000 +0100
|
|
@@ -2,8 +2,6 @@
|
|
# arch/cris/arch-v10/boot/Makefile
|
|
#
|
|
|
|
-OBJCOPYFLAGS = -O binary --remove-section=.bss
|
|
-
|
|
subdir- := compressed rescue
|
|
targets := Image
|
|
|
|
diff -urN linux-2.6.28/arch/cris/arch-v10/boot/compressed/Makefile linux-2.6.28.my/arch/cris/arch-v10/boot/compressed/Makefile
|
|
--- linux-2.6.28/arch/cris/arch-v10/boot/compressed/Makefile 2008-12-25 00:26:37.000000000 +0100
|
|
+++ linux-2.6.28.my/arch/cris/arch-v10/boot/compressed/Makefile 2009-01-12 13:28:33.000000000 +0100
|
|
@@ -6,7 +6,6 @@
|
|
ccflags-y += -O2 $(LINUXINCLUDE)
|
|
ldflags-y += -T $(srctree)/$(src)/decompress.lds
|
|
OBJECTS = $(obj)/head.o $(obj)/misc.o
|
|
-OBJCOPYFLAGS = -O binary --remove-section=.bss
|
|
|
|
quiet_cmd_image = BUILD $@
|
|
cmd_image = cat $(obj)/decompress.bin $(obj)/piggy.gz > $@
|
|
diff -urN linux-2.6.28/arch/cris/arch-v10/boot/rescue/Makefile linux-2.6.28.my/arch/cris/arch-v10/boot/rescue/Makefile
|
|
--- linux-2.6.28/arch/cris/arch-v10/boot/rescue/Makefile 2008-12-25 00:26:37.000000000 +0100
|
|
+++ linux-2.6.28.my/arch/cris/arch-v10/boot/rescue/Makefile 2009-01-12 13:28:40.000000000 +0100
|
|
@@ -5,7 +5,6 @@
|
|
ccflags-y += -O2 $(LINUXINCLUDE)
|
|
asflags-y += $(LINUXINCLUDE)
|
|
ldflags-y += -T $(srctree)/$(src)/rescue.lds
|
|
-OBJCOPYFLAGS = -O binary --remove-section=.bss
|
|
obj-$(CONFIG_ETRAX_AXISFLASHMAP) = head.o
|
|
OBJECT := $(obj)/head.o
|
|
|