fffbd2c9f7
i2pd (I2P Daemon) is a full-featured C++ implementation of I2P client. I2P (Invisible Internet Protocol) is a universal anonymous network layer. All communications over I2P are anonymous and end-to-end encrypted, participants don't reveal their real IP addresses. http://i2pd.website Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> [Thomas: - Add third patch to not install the license file in /usr/LICENSE and the source code in /usr/src instead of using a post-install-target hook to remove /usr/LICENSE and /usr/src. Indeed, we're not sure if /usr/src contains only stuff installed by this package. - Clarify the comment that explains why -DTHREADS_PTHREAD_ARG=OFF is passed, especially because it's only needed for older versions of CMake, and causes a warning with newer versions of CMake. - Propagate architecture dependencies to the Config.in comment about the exception_ptr requirement.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
70 lines
3.1 KiB
Diff
70 lines
3.1 KiB
Diff
From 1d934bd543360bfdd40e1501d16d8beb2016ccd8 Mon Sep 17 00:00:00 2001
|
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
Date: Mon, 5 Mar 2018 14:55:54 +0100
|
|
Subject: [PATCH] Install libi2pdclient
|
|
|
|
When building with -DBUILD_SHARED_LIBS=ON, libi2pdclient is not
|
|
installed on target so install it by calling install. Moreover, rename
|
|
i2pdclient to libi2pdclient so library is installed with correct name.
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
---
|
|
build/CMakeLists.txt | 16 +++++++++++-----
|
|
1 file changed, 11 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/build/CMakeLists.txt b/build/CMakeLists.txt
|
|
index a1c8957b..364c3304 100644
|
|
--- a/build/CMakeLists.txt
|
|
+++ b/build/CMakeLists.txt
|
|
@@ -120,7 +120,13 @@ set (CLIENT_SRC
|
|
if(WITH_WEBSOCKETS)
|
|
list (APPEND CLIENT_SRC "${LIBI2PD_CLIENT_SRC_DIR}/Websocket.cpp")
|
|
endif ()
|
|
-add_library(i2pdclient ${CLIENT_SRC})
|
|
+add_library(libi2pdclient ${CLIENT_SRC})
|
|
+set_target_properties(libi2pdclient PROPERTIES PREFIX "")
|
|
+install(TARGETS libi2pdclient
|
|
+ EXPORT libi2pdclient
|
|
+ ARCHIVE DESTINATION lib
|
|
+ LIBRARY DESTINATION lib
|
|
+ COMPONENT Libraries)
|
|
|
|
set(DAEMON_SRC_DIR ../daemon)
|
|
|
|
@@ -304,7 +310,7 @@ if (WITH_PCH)
|
|
WORKING_DIRECTORY ${CMAKE_BINARY_DIR}
|
|
)
|
|
target_compile_options(libi2pd PRIVATE /FIstdafx.h /Yustdafx.h /Zm155 "/Fp${CMAKE_BINARY_DIR}/stdafx.dir/$<CONFIG>/stdafx.pch")
|
|
- target_compile_options(i2pdclient PRIVATE /FIstdafx.h /Yustdafx.h /Zm155 "/Fp${CMAKE_BINARY_DIR}/stdafx.dir/$<CONFIG>/stdafx.pch")
|
|
+ target_compile_options(libi2pdclient PRIVATE /FIstdafx.h /Yustdafx.h /Zm155 "/Fp${CMAKE_BINARY_DIR}/stdafx.dir/$<CONFIG>/stdafx.pch")
|
|
else()
|
|
string(TOUPPER ${CMAKE_BUILD_TYPE} BTU)
|
|
get_directory_property(DEFS DEFINITIONS)
|
|
@@ -313,12 +319,12 @@ if (WITH_PCH)
|
|
COMMAND ${CMAKE_CXX_COMPILER} ${FLAGS} -c ${CMAKE_CURRENT_SOURCE_DIR}/../libi2pd/stdafx.h -o ${CMAKE_BINARY_DIR}/stdafx.h.gch
|
|
)
|
|
target_compile_options(libi2pd PRIVATE -include libi2pd/stdafx.h)
|
|
- target_compile_options(i2pdclient PRIVATE -include libi2pd/stdafx.h)
|
|
+ target_compile_options(libi2pdclient PRIVATE -include libi2pd/stdafx.h)
|
|
endif()
|
|
target_link_libraries(libi2pd stdafx)
|
|
endif()
|
|
|
|
-target_link_libraries(i2pdclient libi2pd)
|
|
+target_link_libraries(libi2pdclient libi2pd)
|
|
|
|
find_package ( Boost COMPONENTS system filesystem program_options date_time REQUIRED )
|
|
if(NOT DEFINED Boost_INCLUDE_DIRS)
|
|
@@ -451,7 +457,7 @@ if (WITH_BINARY)
|
|
if (WITH_STATIC)
|
|
set(DL_LIB ${CMAKE_DL_LIBS})
|
|
endif()
|
|
- target_link_libraries( "${PROJECT_NAME}" libi2pd i2pdclient ${DL_LIB} ${Boost_LIBRARIES} ${OPENSSL_LIBRARIES} ${ZLIB_LIBRARY} ${CMAKE_THREAD_LIBS_INIT} ${MINGW_EXTRA} ${DL_LIB} ${CMAKE_REQUIRED_LIBRARIES})
|
|
+ target_link_libraries( "${PROJECT_NAME}" libi2pd libi2pdclient ${DL_LIB} ${Boost_LIBRARIES} ${OPENSSL_LIBRARIES} ${ZLIB_LIBRARY} ${CMAKE_THREAD_LIBS_INIT} ${MINGW_EXTRA} ${DL_LIB} ${CMAKE_REQUIRED_LIBRARIES})
|
|
|
|
install(TARGETS "${PROJECT_NAME}" RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} COMPONENT Runtime)
|
|
set (APPS "\${CMAKE_INSTALL_PREFIX}/bin/${PROJECT_NAME}${CMAKE_EXECUTABLE_SUFFIX}")
|
|
--
|
|
2.14.1
|
|
|