11357a11e5
[Peter: fix libintl handling, pass --includedir / --libdir] Signed-off-by: Simon Dawson <spdawson@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
135 lines
6.2 KiB
Diff
135 lines
6.2 KiB
Diff
Fix compile and link errors related to the minixpm code.
|
|
|
|
Signed-off-by: Simon Dawson <spdawson@gmail.com>
|
|
|
|
diff -Nurp a/hacks/Makefile.in b/hacks/Makefile.in
|
|
--- a/hacks/Makefile.in 2013-07-16 10:23:32.000000000 +0100
|
|
+++ b/hacks/Makefile.in 2013-09-22 18:47:56.389238980 +0100
|
|
@@ -73,17 +73,22 @@ UTIL_SRCS = $(UTILS_SRC)/alpha.c $(UTILS
|
|
$(UTILS_SRC)/minixpm.c \
|
|
$(UTILS_SRC)/yarandom.c $(UTILS_SRC)/erase.c \
|
|
$(UTILS_SRC)/xshm.c $(UTILS_SRC)/xdbe.c \
|
|
- $(UTILS_SRC)/textclient.c
|
|
+ $(UTILS_SRC)/colorbars.c \
|
|
+ $(UTILS_SRC)/fade.c \
|
|
+ $(UTILS_SRC)/textclient.c \
|
|
+ $(UTILS_SRC)/overlay.c
|
|
UTIL_OBJS = $(UTILS_BIN)/alpha.o $(UTILS_BIN)/colors.o \
|
|
$(UTILS_BIN)/grabclient.o \
|
|
$(UTILS_BIN)/hsv.o $(UTILS_BIN)/resources.o \
|
|
$(UTILS_BIN)/spline.o $(UTILS_BIN)/usleep.o \
|
|
$(UTILS_BIN)/visual.o $(UTILS_BIN)/logo.o \
|
|
- $(UTILS_SRC)/minixpm.c \
|
|
+ $(UTILS_BIN)/minixpm.o \
|
|
$(UTILS_BIN)/yarandom.o $(UTILS_BIN)/erase.o \
|
|
$(UTILS_BIN)/xshm.o $(UTILS_BIN)/xdbe.o \
|
|
$(UTILS_BIN)/colorbars.o \
|
|
- $(UTILS_SRC)/textclient.o
|
|
+ $(UTILS_BIN)/fade.o \
|
|
+ $(UTILS_BIN)/textclient.o \
|
|
+ $(UTILS_BIN)/overlay.o
|
|
|
|
SRCS = attraction.c blitspin.c bouboule.c braid.c bubbles.c \
|
|
bubbles-default.c decayscreen.c deco.c drift.c flag.c \
|
|
@@ -559,11 +564,11 @@ xscreensaver-sgigl: xscreensaver-sgigl.c
|
|
attraction: attraction.o $(HACK_OBJS) $(COL) $(SPL)
|
|
$(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(COL) $(SPL) $(HACK_LIBS)
|
|
|
|
-blitspin: blitspin.o $(HACK_OBJS) $(GRAB) $(XPM)
|
|
- $(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(GRAB) $(XPM) $(XPM_LIBS)
|
|
+blitspin: blitspin.o $(HACK_OBJS) $(GRAB) $(XPM) $(MINIXPM)
|
|
+ $(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(GRAB) $(XPM) $(MINIXPM) $(XPM_LIBS)
|
|
|
|
-bubbles: bubbles.o $(HACK_OBJS) bubbles-default.o $(XPM)
|
|
- $(CC_HACK) -o $@ $@.o $(HACK_OBJS) bubbles-default.o $(XPM) $(XPM_LIBS)
|
|
+bubbles: bubbles.o $(HACK_OBJS) bubbles-default.o $(XPM) $(MINIXPM)
|
|
+ $(CC_HACK) -o $@ $@.o $(HACK_OBJS) bubbles-default.o $(XPM) $(MINIXPM) $(XPM_LIBS)
|
|
|
|
decayscreen: decayscreen.o $(HACK_OBJS) $(GRAB)
|
|
$(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(GRAB) $(HACK_LIBS)
|
|
@@ -604,8 +609,8 @@ moire: moire.o $(HACK_OBJS) $(COL) $(S
|
|
moire2: moire2.o $(HACK_OBJS) $(COL) $(DBE)
|
|
$(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(COL) $(DBE) $(HACK_LIBS)
|
|
|
|
-noseguy: noseguy.o $(HACK_OBJS) $(XPM) $(TEXT)
|
|
- $(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(XPM) $(TEXT) $(XPM_LIBS) $(TEXT_LIBS)
|
|
+noseguy: noseguy.o $(HACK_OBJS) $(XPM) $(TEXT) $(MINIXPM)
|
|
+ $(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(XPM) $(TEXT) $(MINIXPM) $(XPM_LIBS) $(TEXT_LIBS)
|
|
|
|
pedal: pedal.o $(HACK_OBJS) $(HSV) $(ERASE)
|
|
$(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(HSV) $(ERASE) $(HACK_LIBS)
|
|
@@ -658,14 +663,14 @@ interference: interference.o $(HACK_OBJ
|
|
truchet: truchet.o $(HACK_OBJS) $(COL)
|
|
$(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(COL) $(HACK_LIBS)
|
|
|
|
-bsod: bsod.o $(HACK_OBJS) $(GRAB) $(APPLE2) $(XPM)
|
|
- $(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(GRAB) $(APPLE2) $(XPM) $(XPM_LIBS)
|
|
+bsod: bsod.o $(HACK_OBJS) $(GRAB) $(APPLE2) $(XPM) $(MINIXPM)
|
|
+ $(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(GRAB) $(APPLE2) $(XPM) $(MINIXPM) $(XPM_LIBS)
|
|
|
|
apple2: apple2.o apple2-main.o $(HACK_OBJS) $(ATV) $(GRAB) $(TEXT)
|
|
$(CC_HACK) -o $@ $@.o apple2-main.o $(HACK_OBJS) $(ATV) $(GRAB) $(TEXT) $(XPM_LIBS) $(TEXT_LIBS)
|
|
|
|
-xanalogtv: xanalogtv.o $(HACK_OBJS) $(ATV) $(GRAB) $(XPM)
|
|
- $(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(ATV) $(GRAB) $(XPM) $(XPM_LIBS) $(HACK_LIBS)
|
|
+xanalogtv: xanalogtv.o $(HACK_OBJS) $(ATV) $(GRAB) $(XPM) $(MINIXPM)
|
|
+ $(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(ATV) $(GRAB) $(XPM) $(MINIXPM) $(XPM_LIBS) $(HACK_LIBS)
|
|
|
|
distort: distort.o $(HACK_OBJS) $(GRAB) $(SHM)
|
|
$(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(GRAB) $(SHM) $(HACK_LIBS)
|
|
@@ -688,8 +693,8 @@ compass: compass.o $(HACK_OBJS) $(DBE)
|
|
squiral: squiral.o $(HACK_OBJS) $(COL)
|
|
$(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(COL) $(HACK_LIBS)
|
|
|
|
-xflame: xflame.o $(HACK_OBJS) $(SHM) $(XPM)
|
|
- $(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(SHM) $(XPM) $(XPM_LIBS)
|
|
+xflame: xflame.o $(HACK_OBJS) $(SHM) $(XPM) $(MINIXPM)
|
|
+ $(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(SHM) $(XPM) $(MINIXPM) $(XPM_LIBS)
|
|
|
|
wander: wander.o $(HACK_OBJS) $(COL) $(ERASE)
|
|
$(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(COL) $(ERASE) $(HACK_LIBS)
|
|
@@ -703,8 +708,8 @@ critical: critical.o $(HACK_OBJS) $(COL)
|
|
phosphor: phosphor.o $(HACK_OBJS) $(TEXT) $(COL)
|
|
$(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(TEXT) $(COL) $(HACK_LIBS) $(TEXT_LIBS)
|
|
|
|
-xmatrix: xmatrix.o $(HACK_OBJS) $(TEXT) $(XPM)
|
|
- $(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(TEXT) $(XPM) $(XPM_LIBS) $(TEXT_LIBS)
|
|
+xmatrix: xmatrix.o $(HACK_OBJS) $(TEXT) $(XPM) $(MINIXPM)
|
|
+ $(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(TEXT) $(XPM) $(MINIXPM) $(XPM_LIBS) $(TEXT_LIBS)
|
|
|
|
petri: petri.o $(HACK_OBJS) $(COL) $(SPL)
|
|
$(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(COL) $(SPL) $(HACK_LIBS)
|
|
@@ -787,8 +792,8 @@ cloudlife: cloudlife.o $(HACK_OBJS) $(CO
|
|
fontglide: fontglide.o $(HACK_OBJS) $(DBE) $(TEXT)
|
|
$(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(DBE) $(TEXT) $(HACK_LIBS) $(TEXT_LIBS)
|
|
|
|
-pong: pong.o $(HACK_OBJS) $(ATV) $(GRAB) $(XPM)
|
|
- $(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(ATV) $(GRAB) $(XPM) $(XPM_LIBS) $(HACK_LIBS)
|
|
+pong: pong.o $(HACK_OBJS) $(ATV) $(GRAB) $(XPM) $(MINIXPM)
|
|
+ $(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(ATV) $(GRAB) $(XPM) $(MINIXPM) $(XPM_LIBS) $(HACK_LIBS)
|
|
|
|
wormhole: wormhole.o $(HACK_OBJS)
|
|
$(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(HACK_LIBS)
|
|
@@ -856,8 +861,8 @@ braid: braid.o $(XLOCK_OBJS) $(ERASE)
|
|
drift: drift.o $(XLOCK_OBJS) $(ERASE)
|
|
$(CC_HACK) -o $@ $@.o $(XLOCK_OBJS) $(ERASE) $(HACK_LIBS)
|
|
|
|
-flag: flag.o $(XLOCK_OBJS) $(XPM)
|
|
- $(CC_HACK) -o $@ $@.o $(XLOCK_OBJS) $(XPM) $(XPM_LIBS)
|
|
+flag: flag.o $(XLOCK_OBJS) $(XPM) $(MINIXPM)
|
|
+ $(CC_HACK) -o $@ $@.o $(XLOCK_OBJS) $(XPM) $(MINIXPM) $(XPM_LIBS)
|
|
|
|
forest: forest.o $(XLOCK_OBJS) $(ERASE)
|
|
$(CC_HACK) -o $@ $@.o $(XLOCK_OBJS) $(ERASE) $(HACK_LIBS)
|
|
@@ -959,8 +964,8 @@ thornbird: thornbird.o $(XLOCK_OBJS)
|
|
$(CC_HACK) -o $@ $@.o $(XLOCK_OBJS) $(HACK_LIBS)
|
|
|
|
PACOBJS=pacman_ai.o pacman_level.o
|
|
-pacman: pacman.o $(PACOBJS) $(XLOCK_OBJS) $(XPM)
|
|
- $(CC_HACK) -o $@ $@.o $(PACOBJS) $(XLOCK_OBJS) $(XPM) $(XPM_LIBS)
|
|
+pacman: pacman.o $(PACOBJS) $(XLOCK_OBJS) $(XPM) $(MINIXPM)
|
|
+ $(CC_HACK) -o $@ $@.o $(PACOBJS) $(XLOCK_OBJS) $(XPM) $(MINIXPM) $(XPM_LIBS)
|
|
|
|
fiberlamp: fiberlamp.o $(XLOCK_OBJS)
|
|
$(CC_HACK) -o $@ $@.o $(XLOCK_OBJS) $(HACK_LIBS)
|