8fb0721eb7
- add selinux support; - add erofsfuse support; - add 0001-erofs-utils-fix-multiple-definition-of-sbi.patch [1]; - add 0002-erofs-utils-fuse-fix-linking-when-using-with-selinux.patch [2]; - add 0003-erofs-utils-fuse-disable-backtrace-if-unsupported.patch. [1] https://git.kernel.org/pub/scm/linux/kernel/git/xiang/erofs-utils.git/patch/?id=6c938b755682629a26f85e5540f40c0d316130ed [2] https://git.kernel.org/pub/scm/linux/kernel/git/xiang/erofs-utils.git/patch/?id=f1f9659e98ea925a100e50332309955f5b2b4234 Signed-off-by: Gao Xiang <hsiangkao@aol.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
34 lines
1.3 KiB
Diff
34 lines
1.3 KiB
Diff
From f1f9659e98ea925a100e50332309955f5b2b4234 Mon Sep 17 00:00:00 2001
|
|
From: David Michael <fedora.dm0@gmail.com>
|
|
Date: Thu, 10 Dec 2020 21:29:43 -0500
|
|
Subject: erofs-utils: fuse: fix linking when using --with-selinux
|
|
|
|
The libselinux functions selabel_open and selabel_close are called
|
|
by lib/config.c, so include libselinux in CFLAGS and LIBS to fix
|
|
building erofsfuse.
|
|
|
|
Link: https://lore.kernel.org/r/87360dnkh4.fsf@gmail.com
|
|
Signed-off-by: David Michael <fedora.dm0@gmail.com>
|
|
Reviewed-and-tested-by: Li Guifu <bluce.lee@aliyun.com>
|
|
Signed-off-by: Gao Xiang <hsiangkao@aol.com>
|
|
---
|
|
fuse/Makefile.am | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/fuse/Makefile.am b/fuse/Makefile.am
|
|
index f14f6fd..e7757bc 100644
|
|
--- a/fuse/Makefile.am
|
|
+++ b/fuse/Makefile.am
|
|
@@ -5,6 +5,6 @@ AUTOMAKE_OPTIONS = foreign
|
|
bin_PROGRAMS = erofsfuse
|
|
erofsfuse_SOURCES = dir.c main.c
|
|
erofsfuse_CFLAGS = -Wall -Werror -I$(top_srcdir)/include
|
|
-erofsfuse_CFLAGS += -DFUSE_USE_VERSION=26 ${libfuse_CFLAGS}
|
|
-erofsfuse_LDADD = $(top_builddir)/lib/liberofs.la ${libfuse_LIBS} ${liblz4_LIBS}
|
|
+erofsfuse_CFLAGS += -DFUSE_USE_VERSION=26 ${libfuse_CFLAGS} ${libselinux_CFLAGS}
|
|
+erofsfuse_LDADD = $(top_builddir)/lib/liberofs.la ${libfuse_LIBS} ${liblz4_LIBS} ${libselinux_LIBS}
|
|
|
|
--
|
|
cgit 1.2.3-1.el7
|
|
|