c970d7d640
Fixes the following security issues: - CVE-2013-1752: Change use of readline() in :class:`imaplib.IMAP4_SSL` to limit line length - CVE-2018-14647: The C accelerated _elementtree module now initializes hash randomization salt from _Py_HashSecret instead of libexpat's default CSPRNG. For more details, see the NEWS file: https://github.com/python/cpython/blob/v2.7.16/Misc/NEWS.d/2.7.16rc1.rst Refresh patches, drop now upstream package/python/0035-bpo-35746-Fix-segfault-in-ssl-s-cert-parser-GH-11569.patch and adjust hash of LICENSE file for a change of copyright years. run-tests results: 16:05:41 TestPython2 Starting 16:05:42 TestPython2 Building 16:11:26 TestPython2 Building done 16:11:32 TestPython2 Cleaning up . ---------------------------------------------------------------------- Ran 1 test in 351.905s OK Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
56 lines
1.8 KiB
Diff
56 lines
1.8 KiB
Diff
From e789487c783f75c17a8951bd5324c86ceefde407 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Tue, 7 Mar 2017 22:30:56 +0100
|
|
Subject: [PATCH] Do not install the idle editor
|
|
|
|
IDLE is the Python IDE built with the tkinter GUI toolkit. Since it's
|
|
highly unlikely to ever be useful in an embedded Linux system
|
|
generated by Buildroot, this patch simply disables the installation of
|
|
idle and the related Python modules. It saves 800 KB-900 KB of
|
|
installed .pyc files.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
[Peter: update for 2.7.16]
|
|
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
|
|
---
|
|
Makefile.pre.in | 2 --
|
|
setup.py | 2 +-
|
|
2 files changed, 1 insertion(+), 3 deletions(-)
|
|
|
|
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
|
index a0473096c1..750057fb96 100644
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -1055,7 +1055,6 @@ LIBSUBDIRS= site-packages \
|
|
json \
|
|
logging csv importlib wsgiref \
|
|
ctypes ctypes/macholib \
|
|
- idlelib idlelib/Icons \
|
|
distutils distutils/command \
|
|
multiprocessing multiprocessing/dummy \
|
|
unittest \
|
|
@@ -1071,7 +1070,6 @@ TESTSUBDIRS = test test/audiodata test/capath test/data \
|
|
email/test email/test/data \
|
|
json/tests \
|
|
ctypes/test \
|
|
- idlelib/idle_test \
|
|
distutils/tests \
|
|
unittest/test
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index f439cbadc2..227187681e 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -2278,7 +2278,7 @@ def main():
|
|
import warnings
|
|
warnings.filterwarnings("ignore",category=DeprecationWarning)
|
|
|
|
- scripts = ['Tools/scripts/idle', 'Lib/smtpd.py']
|
|
+ scripts = ['Lib/smtpd.py']
|
|
if not '--disable-pydoc' in sysconfig.get_config_var("CONFIG_ARGS"):
|
|
scripts += [ 'Tools/scripts/pydoc' ]
|
|
if not '--disable-lib2to3' in sysconfig.get_config_var("CONFIG_ARGS"):
|
|
--
|
|
2.11.0
|
|
|