kumquat-buildroot/package/e2fsprogs/0002-fuse2fs-might-need-librt.patch
Yann E. MORIN 0409d66d56 package/e2fsprogs: fix 0002 patch
Patch 0002-fuse2fs-might-need-librt.patch introduced a new configure.ac
variable that should contain whether -lrt is needed to gt clock_gettime.

However, it forgot to propagate that variable into the Makefiles.

Because e2fprogs is not using automake (just autoconf), the configure
variables are not automatically propagated; it needs to be done
manually.

Fixes:
    http://autobuild.buildroot.org/results/edf/edf4195d33720d51031a84c3bdb6b6b0ed3b4731/
    http://autobuild.buildroot.org/results/987/987efb687870062c509361eaefd0ff80043392f8/
    http://autobuild.buildroot.org/results/f58/f58b5f8f5cd069b63aae4249bc7aefb145789b7d/
    [...]

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2016-07-12 10:48:08 +02:00

64 lines
1.9 KiB
Diff

From 14d9e94315cd8144ac72d368c45e70869a66799c Mon Sep 17 00:00:00 2001
From: Gustavo Zacarias <gustavo@zacarias.com.ar>
Date: Thu, 9 Jun 2016 07:47:03 -0300
Subject: [PATCH] fuse2fs: might need librt
It uses clock_gettime() which in older glibc versions is in librt.
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
[yann.morin.1998@free.fr: properly expand it in the Makefile]
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
---
Patch status: sent to linux-ext4 ML
configure.ac | 5 +++++
misc/Makefile.in | 3 ++-
2 files changed, 7 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 67d7231..a387dfd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1162,6 +1162,11 @@ if test "$ac_cv_func_dlopen" = yes ; then
fi
AC_SUBST(MAGIC_LIB)
dnl
+dnl Check to see if librt is required for clock_gettime() (glibc < 2.17)
+dnl
+AC_CHECK_LIB(rt, clock_gettime, [CLOCK_GETTIME_LIB=-lrt])
+AC_SUBST(CLOCK_GETTIME_LIB)
+dnl
dnl Check to see if the FUSE library is -lfuse or -losxfuse
dnl
FUSE_CMT=
diff --git a/misc/Makefile.in b/misc/Makefile.in
index 43e3c7e..070a6e3 100644
--- a/misc/Makefile.in
+++ b/misc/Makefile.in
@@ -387,7 +387,8 @@ fuse2fs: $(FUSE2FS_OBJS) $(DEPLIBS) $(DEPLIBBLKID) $(DEPLIBUUID) \
$(LIBEXT2FS)
$(E) " LD $@"
$(Q) $(CC) $(ALL_LDFLAGS) -o fuse2fs $(FUSE2FS_OBJS) $(LIBS) \
- $(LIBFUSE) $(LIBBLKID) $(LIBUUID) $(LIBEXT2FS) $(LIBINTL)
+ $(LIBFUSE) $(LIBBLKID) $(LIBUUID) $(LIBEXT2FS) $(LIBINTL) \
+ $(CLOCK_GETTIME_LIB)
journal.o: $(srcdir)/../debugfs/journal.c
$(E) " CC $@"
diff --git a/misc/Makefile.in b/misc/Makefile.in
index 43e3c7e..070a6e3 100644
--- a/misc/Makefile.in
+++ b/misc/Makefile.in
@@ -32,6 +32,8 @@
@FUSE_CMT@FUSE_PROG= fuse2fs
+CLOCK_GETTIME_LIB = @CLOCK_GETTIME_LIB@
+
SPROGS= mke2fs badblocks tune2fs dumpe2fs $(BLKID_PROG) logsave \
$(E2IMAGE_PROG) @FSCK_PROG@ e2undo
USPROGS= mklost+found filefrag e2freefrag $(UUIDD_PROG) \
--
2.7.3