96d3d01796
The reason for combining these patches is because the old version of setools is not compatible iwth libsepol 2.7. If a user where to do a git pull on a patch that only updates libsepol or setools, the build would fail to compile. setools has been completely rewritten in python instead of C. The current version of setools includes a few programs that require python-qt5 or python-networkx to run, however the package does not check to see if these exist when compiling, and will install the scripts to the target directory even if they don't exist. In the case of python-networkx, this package is not available on Buildroot. The scripts that require them are: sedta and seinfoflow. In the case of python-qt5, qpol is the script that requires it. Some setools.mk notes to get the package to compile: - Convert the package .mk to use python-package instead of autotools-package. - setup.py hard codes base_lib_dirs to point to several host directories. To fix this, sed is used before compiling to point the base_lib_dirs to the staging directory. - setup.py also includes the "Werror" flag, however compilers before gcc6 cause a few autogenerated variables to not be initialized before use, causing the build to fail. To fix this, a patch is provided that removes the Werror flag. - Remove sedta and seinfoflow from the target system after install. These packages rely on the package python-networkx which is not available in buildroot. - Remove the installed apol package and the setoolsgui directory from the target directory if python-qt5 is not selected. Other changes: - Removed all patches, as they are not compatible with the new version of setools. - Add COPYING, COPYING.GPL, and COPYING.LGPL to setools.hash Signed-off-by: Adam Duskett <Adamduskett@outlook.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
35 lines
1.1 KiB
Diff
35 lines
1.1 KiB
Diff
From 16b2b0e21e10727065042a1baabd1a887757c65c Mon Sep 17 00:00:00 2001
|
|
From: Adam Duskett <Adamduskett@outlook.com>
|
|
Date: Mon, 9 Oct 2017 16:29:36 -0400
|
|
Subject: [PATCH] Makefile: revert libsepol: use ln --relative to create .so symlinks
|
|
|
|
This reverts 71393a181d63c9baae5fe8dcaeb9411d1f253998
|
|
|
|
ln --relative is too recent to be available in all distributions,
|
|
especially enterprise-grade distros that can stick around as long as
|
|
they are maintained (up to 10 years in some cases?).
|
|
|
|
For the sake of Buildroot, revert the upstream patch.
|
|
|
|
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
|
---
|
|
src/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/Makefile b/src/Makefile
|
|
index 040921d..e811c9e 100644
|
|
--- a/src/Makefile
|
|
+++ b/src/Makefile
|
|
@@ -92,7 +92,7 @@ install: all
|
|
ifeq ($(STATIC),)
|
|
test -d $(SHLIBDIR) || install -m 755 -d $(SHLIBDIR)
|
|
install -m 755 $(LIBSO) $(SHLIBDIR)
|
|
- $(LN) -sf --relative $(SHLIBDIR)/$(LIBSO) $(LIBDIR)/$(TARGET)
|
|
+ cd $(LIBDIR) && ln -sf ../../`basename $(SHLIBDIR)`/$(LIBSO) $(TARGET)
|
|
endif
|
|
|
|
relabel:
|
|
--
|
|
2.13.6
|
|
|