ace8179deb
With the addition of support for custom opensbi version in commit
5c7166d387
(boot/opensbi: add support for version configuration), we can no
longer be sure that the Buildroot patches can be applied - So move them to a
0.9 subdir to ensure they are only applied when the _LATEST_VERSION is used.
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
38 lines
1.3 KiB
Diff
38 lines
1.3 KiB
Diff
From f5871e1f3650d6c8a032928cb5d8ca00c275c377 Mon Sep 17 00:00:00 2001
|
|
From: Alistair Francis <alistair.francis@wdc.com>
|
|
Date: Fri, 15 Feb 2019 14:57:41 -0800
|
|
Subject: [PATCH] Makefile: Don't specify mabi or march
|
|
|
|
To avoid
|
|
can't link double-float modules with soft-float modules
|
|
errors when building 32-bit openSBI don't specify mabi or march.
|
|
|
|
Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
|
|
---
|
|
Makefile | 2 --
|
|
1 file changed, 2 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index ae68f55..10851fc 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -145,7 +145,6 @@ GENFLAGS += $(firmware-genflags-y)
|
|
CFLAGS = -g -Wall -Werror -nostdlib -fno-strict-aliasing -O2
|
|
CFLAGS += -fno-omit-frame-pointer -fno-optimize-sibling-calls
|
|
CFLAGS += -mno-save-restore -mstrict-align
|
|
-CFLAGS += -mabi=$(PLATFORM_RISCV_ABI) -march=$(PLATFORM_RISCV_ISA)
|
|
CFLAGS += -mcmodel=$(PLATFORM_RISCV_CODE_MODEL)
|
|
CFLAGS += $(GENFLAGS)
|
|
CFLAGS += $(platform-cflags-y)
|
|
@@ -158,7 +157,6 @@ CPPFLAGS += $(firmware-cppflags-y)
|
|
ASFLAGS = -g -Wall -nostdlib -D__ASSEMBLY__
|
|
ASFLAGS += -fno-omit-frame-pointer -fno-optimize-sibling-calls
|
|
ASFLAGS += -mno-save-restore -mstrict-align
|
|
-ASFLAGS += -mabi=$(PLATFORM_RISCV_ABI) -march=$(PLATFORM_RISCV_ISA)
|
|
ASFLAGS += -mcmodel=$(PLATFORM_RISCV_CODE_MODEL)
|
|
ASFLAGS += $(GENFLAGS)
|
|
ASFLAGS += $(platform-asflags-y)
|
|
--
|
|
2.20.1
|
|
|