d3af7772d0
The fallback code path didn't work correctly, so fix it. Fixes: http://autobuild.buildroot.net/results/3122287ddea1e316a64ccf0d0dc9415bfefebb49/ Reported-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Waldemar Brodkorb <wbx@openadk.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
41 lines
1.1 KiB
Diff
41 lines
1.1 KiB
Diff
From 381bcb7cb03bb602351a323daf3b69b2d4f45e77 Mon Sep 17 00:00:00 2001
|
|
From: Waldemar Brodkorb <wbx@openadk.org>
|
|
Date: Fri, 26 Aug 2016 15:11:25 +0200
|
|
Subject: [PATCH] fix fallback code and add required realtime library to link
|
|
command
|
|
|
|
Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
|
|
---
|
|
configure.ac | 1 +
|
|
src/posix/thread.c | 2 +-
|
|
2 files changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index cb1de25..018c11c 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -121,6 +121,7 @@ case "${host_os}" in
|
|
;;
|
|
linux*)
|
|
SYS=linux
|
|
+ AC_CHECK_LIB([rt], [posix_spawnp], [VLC_ADD_LIBS([libvlccore],[-lrt])], [], [])
|
|
;;
|
|
bsdi*)
|
|
SYS=bsdi
|
|
diff --git a/src/posix/thread.c b/src/posix/thread.c
|
|
index 07fa71e..8b8595f 100644
|
|
--- a/src/posix/thread.c
|
|
+++ b/src/posix/thread.c
|
|
@@ -85,7 +85,7 @@ static clockid_t vlc_clock_id;
|
|
|
|
static void vlc_clock_setup_once (void)
|
|
{
|
|
-# if (_POSIX_MONOTONIC_CLOCK == 0)
|
|
+# if (_POSIX_MONOTONIC_CLOCK == 0) && (_POSIX_CLOCK_SELECTION > 0)
|
|
long val = sysconf (_SC_MONOTONIC_CLOCK);
|
|
assert (val != 0);
|
|
vlc_clock_id = (val < 0) ? CLOCK_REALTIME : CLOCK_MONOTONIC;
|
|
--
|
|
2.1.4
|
|
|