kumquat-buildroot/package/putty/0002-unix-uxpoll-need-_XOPEN_SOURCE.patch
Baruch Siach 35b72be8fe package/putty: fix build with uClibc
Add patches fixing a number of build issues with uClibc. The issue fixed
in patch #2 has been reported upstream. Patch #3 has been suggested by
upstream but not applied yet.

Drop the _SUBDIR assignment. The configure script moved to top level
directory since upstream commit a947c49bec3 from 2014. This allows
AUTORECONF to find configure.ac.

Fixes:
http://autobuild.buildroot.net/results/801/801e2b2909363b5dcd9735362bb921e017569edc/
http://autobuild.buildroot.net/results/398/3984c6cdd3398645c8ad98bbe23af9090cf4bfcf/
http://autobuild.buildroot.net/results/632/632f93046f9cceffd9b604911542426c10967e0f/

Cc: Alexander Dahl <post@lespocky.de>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2019-03-27 23:22:03 +01:00

40 lines
1.1 KiB
Diff
Raw Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

From c1b9d07d39e33e40d2ad04be176367cf48271cfd Mon Sep 17 00:00:00 2001
From: Baruch Siach <baruch@tkos.co.il>
Date: Tue, 26 Mar 2019 20:00:45 +0200
Subject: [PATCH] unix/uxpoll: need _XOPEN_SOURCE
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
The code needs _XOPEN_SOURCE for some poll() flags.
Fix this build failure with uClibc:
./../unix/uxpoll.c: In function pollwrap_add_fd_rwx:
./../unix/uxpoll.c:75:32: error: POLLRDNORM undeclared (first use in this function); did you mean POLLNVAL?
#define SELECT_R_IN (POLLIN | POLLRDNORM | POLLRDBAND)
^
./../unix/uxpoll.c:87:19: note: in expansion of macro SELECT_R_IN
events |= SELECT_R_IN;
^~~~~~~~~~~
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
---
Upstream status: issue reported to upstream developers
unix/uxpoll.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/unix/uxpoll.c b/unix/uxpoll.c
index bbc5490d125d..6fe6ac7ba0c1 100644
--- a/unix/uxpoll.c
+++ b/unix/uxpoll.c
@@ -1,3 +1,4 @@
+#define _XOPEN_SOURCE
#include <poll.h>
#include "putty.h"
--
2.20.1