c700796388
Signed-off-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
29 lines
804 B
Diff
29 lines
804 B
Diff
refactor -lgd in @LIBS
|
|
|
|
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
|
|
see https://github.com/lstein/Perl-GD/pull/7
|
|
|
|
Index: b/Makefile.PL
|
|
===================================================================
|
|
--- a/Makefile.PL
|
|
+++ b/Makefile.PL
|
|
@@ -34,9 +34,9 @@
|
|
END
|
|
}
|
|
|
|
+push @LIBS, "-lgd";
|
|
@INC = qw(-I/usr/include -I/usr/include/gd) unless @INC;
|
|
@LIBPATH = qw(-L/usr/lib/X11 -L/usr/X11R6/lib -L/usr/X11/lib -L/usr/lib) unless @LIBPATH;
|
|
-@LIBS = qw(-lgd) unless @LIBS;
|
|
|
|
# support for AMD64 libraries
|
|
if (-d '/usr/lib64') {
|
|
@@ -291,7 +291,6 @@
|
|
@$LIBPATH = map {s/^-L// && "-L$_"} split /\s+/,$ldflags;
|
|
@$LIBS = split /\s+/,$libs;
|
|
|
|
- push @$LIBS,"-lgd";
|
|
push @$LIBPATH,"-L$libdir";
|
|
($$lib_gd_path = $libdir) =~ s!/[^/]+$!!;
|
|
$$options = $features;
|