b0b3dc5612
Add a configure option to enable the SELinux support in the busybox configuration from the Buildroot menuconfig. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Clayton Shotwell <clayton.shotwell@rockwellcollins.com> Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
29 lines
963 B
Diff
29 lines
963 B
Diff
From 67eb23d2be8aba3c474dac81a15b0fa11e5847b7 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Mon, 25 Nov 2013 22:51:53 +0100
|
|
Subject: [PATCH] Makefile.flags: strip non -l arguments returned by pkg-config
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
Makefile.flags | 4 +++-
|
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile.flags b/Makefile.flags
|
|
index 307afa7..885e323 100644
|
|
--- a/Makefile.flags
|
|
+++ b/Makefile.flags
|
|
@@ -141,7 +141,9 @@ ifeq ($(CONFIG_SELINUX),y)
|
|
SELINUX_PC_MODULES = libselinux libsepol
|
|
$(eval $(call pkg_check_modules,SELINUX,$(SELINUX_PC_MODULES)))
|
|
CPPFLAGS += $(SELINUX_CFLAGS)
|
|
-LDLIBS += $(if $(SELINUX_LIBS),$(SELINUX_LIBS:-l%=%),$(SELINUX_PC_MODULES:lib%=%))
|
|
+LDLIBS += $(if $(SELINUX_LIBS),\
|
|
+ $(patsubst -l%,%,$(filter -l%,$(SELINUX_LIBS))),\
|
|
+ $(SELINUX_PC_MODULES:lib%=%))
|
|
endif
|
|
|
|
ifeq ($(CONFIG_EFENCE),y)
|
|
--
|
|
1.8.1.2
|
|
|