6e6e8d37b5
Bump Python3 version to 3.6.2. Patches dropped: "Support PGEN_FOR_BUILD and FREEZE_IMPORTLIB_FOR_BUILD" Rationale: With commit 9d02f562961efd12d3c8317a10916db7f77330cc, code generation step of building CPython now became explicit (instead of always performed as a part of 'make' invocation) and more granular. We no longer need to use Parser/pgen at all and tricking the build system into using different Programs/_freeze_importlib can be done as a part of recipe. Additional info about the build change can be found at https://bugs.python.org/issue23404 Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com> Tested-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
34 lines
1013 B
Diff
34 lines
1013 B
Diff
From e52d4868cc1192f7e1c147aebaf4fc6f7de30357 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Wed, 23 Dec 2015 11:50:11 +0100
|
|
Subject: [PATCH] Add an option to disable NIS
|
|
|
|
NIS is not necessarily available in uClibc, so we need an option to
|
|
not compile support for it.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
configure.ac | 6 ++++++
|
|
1 file changed, 6 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index c7742faf41..42a871bb09 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -3135,6 +3135,12 @@ AC_ARG_ENABLE(codecs-cjk,
|
|
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _codecs_kr _codecs_jp _codecs_cn _codecs_tw _codecs_hk _codecs_iso2022"
|
|
fi])
|
|
|
|
+AC_ARG_ENABLE(nis,
|
|
+ AS_HELP_STRING([--disable-nis], [disable NIS]),
|
|
+ [ if test "$enableval" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} nis"
|
|
+ fi])
|
|
+
|
|
AC_SUBST(TK)
|
|
AC_ARG_ENABLE(tk,
|
|
AS_HELP_STRING([--disable-tk], [disable tk]),
|
|
--
|
|
2.13.5
|
|
|