0012baabfc
Also remove upstream patch 0033.
Fixes the following security issues:
- bpo-36216: Changes urlsplit() to raise ValueError when the URL contains
characters that decompose under IDNA encoding (NFKC-normalization) into
characters that affect how the URL is parsed.
- bpo-35746: [CVE-2019-5010] Fix a NULL pointer deref in ssl module. The
cert parser did not handle CRL distribution points with empty DP or URI
correctly. A malicious or buggy certificate can result into segfault.
Vulnerability (TALOS-2018-0758) reported by Colin Read and Nicolas Edet of
Cisco.
- bpo-35121: Don’t send cookies of domain A without Domain attribute to
domain B when domain A is a suffix match of domain B while using a
cookiejar with http.cookiejar.DefaultCookiePolicy policy. Patch by
Karthikeyan Singaravelan.
For more details, see the changelog:
https://docs.python.org/3.7/whatsnew/changelog.html#python-3-7-3-final
Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
(cherry picked from commit 6afc83b60f
)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
28 lines
781 B
Diff
28 lines
781 B
Diff
From 8ec1677d16bef6d6ee5cee4ff004dfa3d0428e88 Mon Sep 17 00:00:00 2001
|
|
From: Vanya Sergeev <vsergeev@gmail.com>
|
|
Date: Wed, 23 Dec 2015 11:30:33 +0100
|
|
Subject: [PATCH] Disable buggy_getaddrinfo configure test when cross-compiling
|
|
with IPv6 support
|
|
|
|
Signed-off-by: Vanya Sergeev <vsergeev@gmail.com>
|
|
---
|
|
configure.ac | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index a76b5444df..5f87c4db5a 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -4056,7 +4056,7 @@ fi
|
|
|
|
AC_MSG_RESULT($ac_cv_buggy_getaddrinfo)
|
|
|
|
-if test $have_getaddrinfo = no || test "$ac_cv_buggy_getaddrinfo" = yes
|
|
+if test $have_getaddrinfo = no || test "$cross_compiling" != "yes" -a "$ac_cv_buggy_getaddrinfo" = yes
|
|
then
|
|
if test $ipv6 = yes
|
|
then
|
|
--
|
|
2.13.5
|
|
|