fb6274f5de
This reverts commit 36e635d2d5
.
Python 3.12 is still causing too many build failures, so revert for 2024.02.
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
34 lines
869 B
Diff
34 lines
869 B
Diff
From 58027d25c3cabcf654cb0b31a61d7cbd53dc68c0 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
|
Date: Sat, 18 Aug 2018 10:54:56 +0200
|
|
Subject: [PATCH] Add an option to disable uuid module
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
|
---
|
|
configure.ac | 9 +++++++++
|
|
1 file changed, 9 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index ca6c16491a..ed03b27fb1 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -4267,6 +4267,15 @@ if test "$CURSES" = "no"; then
|
|
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _curses _curses_panel"
|
|
fi
|
|
|
|
+AC_SUBST(UUID)
|
|
+AC_ARG_ENABLE(uuid,
|
|
+ AS_HELP_STRING([--disable-uuid], [disable uuid]),
|
|
+ [ UUID="${enableval}" ], [ UUID=yes ])
|
|
+
|
|
+if test "$UUID" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _uuid"
|
|
+fi
|
|
+
|
|
AC_SUBST(PYDOC)
|
|
|
|
AC_ARG_ENABLE(pydoc,
|
|
--
|
|
2.34.1
|
|
|