c9dcd9e459
The LuaJIT project switches to a rolling release scheme. Now, the version contains the timestamp of its latest commit. The timestamp can be seen in build log: ==== Successfully installed LuaJIT 2.1.1693350652 to /usr ==== diff COPYRIGHT: -Copyright (C) 2005-2022 Mike Pall. All rights reserved. +Copyright (C) 2005-2023 Mike Pall. All rights reserved. Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
27 lines
914 B
Diff
27 lines
914 B
Diff
Do not use a symlink for the binary, simply name it luajit
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/Makefile
|
|
===================================================================
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -50,8 +50,7 @@
|
|
INSTALL_MAN= $(INSTALL_SHARE)/man/man1
|
|
INSTALL_PKGCONFIG= $(INSTALL_LIB)/pkgconfig
|
|
|
|
-INSTALL_TNAME= luajit-$(VERSION)
|
|
-INSTALL_TSYMNAME= luajit
|
|
+INSTALL_TNAME= luajit
|
|
INSTALL_ANAME= libluajit-$(ABIVER).a
|
|
INSTALL_SOSHORT1= libluajit-$(ABIVER).so
|
|
INSTALL_SOSHORT2= libluajit-$(ABIVER).so.$(MAJVER)
|
|
@@ -66,7 +65,6 @@
|
|
INSTALL_SHORT1= $(INSTALL_LIB)/$(INSTALL_SOSHORT1)
|
|
INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT2)
|
|
INSTALL_T= $(INSTALL_BIN)/$(INSTALL_TNAME)
|
|
-INSTALL_TSYM= $(INSTALL_BIN)/$(INSTALL_TSYMNAME)
|
|
INSTALL_PC= $(INSTALL_PKGCONFIG)/$(INSTALL_PCNAME)
|
|
|
|
INSTALL_DIRS= $(INSTALL_BIN) $(INSTALL_LIB) $(INSTALL_INC) $(INSTALL_MAN) \
|