kumquat-buildroot/support/kconfig/patches/15-fix-qconf-moc-rule.patch
Thomas Petazzoni 6997e461fd support/kconfig: upgrade to 3.9-rc2
Our kconfig code is updated to the version of kernel 3.9-rc2. No major
issues during the migration, except:

 * Some conflicts when applying 03-change-config-option-prefix.patch
   due to upstream kernel changes.

 * The need of adding a new patch, 15-fix-qconf-moc-rule.patch, to fix
   the make rule that generates the moc file for the Qt-based
   interface.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Tested-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2013-04-11 09:30:39 +02:00

25 lines
653 B
Diff

Fix the rule that generates the .moc file
The Linux kernel has a "cmd" make function, but we don't have it in
Buildroot, so we need to adjust this rule.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/Makefile
===================================================================
--- a/Makefile
+++ b/Makefile
@@ -307,11 +307,8 @@
$(obj)/qconf.o: $(obj)/qconf.moc
-quiet_cmd_moc = MOC $@
- cmd_moc = $(KC_QT_MOC) -i $< -o $@
-
$(obj)/%.moc: $(src)/%.h $(obj)/.tmp_qtcheck
- $(call cmd,moc)
+ $(KC_QT_MOC) -i $< -o $@
# Extract gconf menu items for I18N support
$(obj)/gconf.glade.h: $(obj)/gconf.glade