22e27da265
Enable static build. gawk builds statically just fine. The shared library check has been removed in 4.1.1. Remove the symlink force hunk from the no-versioned patch. The only user of LN is in the part that this patch disables. Add license file hash. Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
17 lines
640 B
Diff
17 lines
640 B
Diff
Disabled versioned installation of binaries to save space.
|
|
|
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
[Gustavo: update for 4.1.2]
|
|
|
|
diff -Nura gawk-4.1.2.orig/Makefile.in gawk-4.1.2/Makefile.in
|
|
--- gawk-4.1.2.orig/Makefile.in 2015-04-29 16:11:09.367925925 -0300
|
|
+++ gawk-4.1.2/Makefile.in 2015-04-29 16:11:25.308466495 -0300
|
|
@@ -1173,6 +1173,7 @@
|
|
# (This is done universally, which may not always be right, but
|
|
# there's no easy way to distinguish GNU from non-GNU systems.)
|
|
install-exec-hook:
|
|
+foo:
|
|
(cd $(DESTDIR)$(bindir); \
|
|
$(LN) gawk$(EXEEXT) gawk-$(VERSION)$(EXEEXT) 2>/dev/null ; \
|
|
if [ ! -f awk$(EXEEXT) ]; \
|