eddbcee8a0
Patch configure.ac to not assume broken inet_pton in case of cross compiling (avoids double definition), similare patch is used for OpenEmbedded (see [1]). Fixes [2]: host/usr/arm-buildroot-linux-uclibcgnueabi/sysroot/usr/lib/libc.a(ntop.os): In function `inet_pton': ntop.c:(.text+0x4b4): multiple definition of `inet_pton' wsutil/.libs/libwsutil.a(inet_pton.o):inet_pton.c:(.text+0xe0): first defined here collect2: error: ld returned 1 exit status [1] http://cgit.openembedded.org/openembedded/tree/recipes/wireshark/files/fix-configure.patch [2] http://autobuild.buildroot.net/results/b35/b354ba668ca9476c143f5f7ef1b727b0b5672b04 Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
33 lines
976 B
Diff
33 lines
976 B
Diff
From a0657feeb2b349ffda895a53e36ea5c992d871cf Mon Sep 17 00:00:00 2001
|
|
From: Peter Seiderer <ps.report@gmx.net>
|
|
Date: Sat, 31 Oct 2015 22:38:48 +0100
|
|
Subject: [PATCH] configure: do not assume broken inet_pton in case of cross
|
|
compiling
|
|
|
|
Patch configure.ac to not assume broken inet_pton in case of cross
|
|
compiling.
|
|
|
|
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
|
---
|
|
configure.ac | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index aec0548..d640e0c 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -2646,8 +2646,8 @@ int main()
|
|
#endif
|
|
}], [AC_MSG_RESULT(ok);
|
|
have_inet_pton=yes], [AC_MSG_RESULT(broken);
|
|
-have_inet_pton=no], [AC_MSG_RESULT(cross compiling, assume it is broken);
|
|
-have_inet_pton=no])],
|
|
+have_inet_pton=no], [AC_MSG_RESULT([cross compiling, assume it is broken... not here]);
|
|
+have_inet_pton=yes])],
|
|
have_inet_pton=no)
|
|
if test "$have_inet_pton" = no; then
|
|
INET_PTON_LO="inet_pton.lo"
|
|
--
|
|
2.1.4
|
|
|