kumquat-buildroot/package/kvm-unit-tests/0001-Makefile-remove-Werror-to-avoid-build-failures.patch
Fabrice Fontaine fed7ed0285 package/kvm-unit-tests: bump to version 2022-03-08
- Switch site:
  https://git.kernel.org/pub/scm/virt/kvm/kvm-unit-tests.git/commit/?id=f271e1b630a1b8b5f4eae2331654fc1e70abfd66
- Update first patch
- Drop second patch (binutils < 2.23 is not supported by buildroot
  anymore)
- Drop third and fourth patches (already in version)
- This bump will fix the following build failure with powerpc and gcc 11
  thanks to
  0c111b370a

/tmp/ccSlivNE.s:348: Error: `lswx' invalid when little-endian

Fixes:
 - http://autobuild.buildroot.org/results/746e87892ac545e8fb97c17d4bfd7bd7bbc9d8be

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Reviewed-by: Thomas Huth <huth@tuxfamily.org>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
2022-03-17 22:31:01 +01:00

31 lines
1.1 KiB
Diff

From 08e14a662b9e75daec29722e49150869952ba1b6 Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Date: Mon, 20 Nov 2017 22:09:39 +0100
Subject: [PATCH] Makefile: remove -Werror to avoid build failures
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
[Matthew: Refactoring of Thomas Petazzoni's original.]
Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
[Fabrice: updated for 2022-03-08]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
Makefile | 1 -
1 file changed, 1 deletion(-)
diff --git a/Makefile b/Makefile
index 7231334..d9ad42b 100644
--- a/Makefile
+++ b/Makefile
@@ -53,7 +53,7 @@ cc-option = $(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null \
COMMON_CFLAGS += -g $(autodepend-flags) -fno-strict-aliasing -fno-common
COMMON_CFLAGS += -Wall -Wwrite-strings -Wempty-body -Wuninitialized
-COMMON_CFLAGS += -Wignored-qualifiers -Werror -Wno-missing-braces
+COMMON_CFLAGS += -Wignored-qualifiers -Wno-missing-braces
frame-pointer-flag=-f$(if $(KEEP_FRAME_POINTER),no-,)omit-frame-pointer
fomit_frame_pointer := $(call cc-option, $(frame-pointer-flag), "")
-
2.14.2