a4fb3d9f7a
Fixes http://autobuild.buildroot.net/results/cb2/cb2cec1295a40667a3c21060864dd0e65a312c3e Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
29 lines
1.3 KiB
Diff
29 lines
1.3 KiB
Diff
Fix cross-compilation
|
|
|
|
Patch sent upstream: http://article.gmane.org/gmane.comp.gnu.libmicrohttpd/1193
|
|
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
|
|
diff -uNr libmicrohttpd-0.9.35.org/configure.ac libmicrohttpd-0.9.35/configure.ac
|
|
--- libmicrohttpd-0.9.35.org/configure.ac 2014-05-02 20:38:40.000000000 +0200
|
|
+++ libmicrohttpd-0.9.35/configure.ac 2014-05-04 09:17:00.000000000 +0200
|
|
@@ -639,8 +639,7 @@
|
|
SAVE_CPPFLAGS="$CPPFLAGS"
|
|
LDFLAGS="-L$with_gnutls/lib $LDFLAGS"
|
|
CPPFLAGS="-I$with_gnutls/include $CPPFLAGS"
|
|
- AC_CHECK_FILE([$with_gnutls/include/gnutls/gnutls.h],
|
|
- [AC_CHECK_HEADERS([gnutls/gnutls.h],
|
|
+ AC_CHECK_HEADERS([gnutls/gnutls.h],
|
|
[AC_CHECK_LIB([gnutls], [gnutls_priority_set],
|
|
[
|
|
GNUTLS_CPPFLAGS="-I$with_gnutls/include"
|
|
@@ -648,7 +647,7 @@
|
|
GNUTLS_LIBS="-lgnutls"
|
|
AC_CHECK_LIB([gnutls], [gnutls_load_file], [AC_CHECK_LIB([gnutls], [gnutls_privkey_import_x509_raw], [have_gnutls_sni=yes])])
|
|
have_gnutls=yes
|
|
- ])])])
|
|
+ ])])
|
|
AS_IF([test "x$have_gnutls" != "xyes"], [AC_MSG_ERROR([can't find usable libgnutls at specified prefix $with_gnutls])])
|
|
LDFLAGS="$SAVE_LDFLAGS"
|
|
CPPFLAGS="$SAVE_CPPFLAGS"
|