4d6e2902f1
Changeset f1d3e09
(Build shared libraries only as the default) broke the
nettle package.
nettle really wants to statically link its tools, examples and testsuite
against its own libraries. But for a shared-only build, static libraries
are not even built, so the build breaks when trying to link any of them.
Fix that in two ways:
- the proper way, by using whatever libraries are available, with a
preference toward using shared libraries;
- disabling both examples and testsuite since we do not need them.
Fixes numerous build failures:
http://autobuild.buildroot.net/results/e93/e93da743c5b84b1bb6274aeee3fe3b52962c560c/
http://autobuild.buildroot.net/results/51d/51d0138ff39c45603315dcedf1f654c18604e1a8/
http://autobuild.buildroot.net/results/521/521d979658e402103f1a18fcfeab3f9705f0c000/
...
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Peter Korsgaard <jacmet@uclibc.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
21 lines
562 B
Diff
21 lines
562 B
Diff
Makefile: disable testsuite and example
|
|
|
|
We do not need them in the context of Buildroot.
|
|
|
|
Also, they break for a shared-only build (but it's fixed in patch 0001).
|
|
|
|
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
|
|
|
diff -durN nettle-2.7.1.orig/Makefile.in nettle-2.7.1/Makefile.in
|
|
--- nettle-2.7.1.orig/Makefile.in 2013-05-28 16:21:54.000000000 +0200
|
|
+++ nettle-2.7.1/Makefile.in 2014-12-12 19:57:12.499805574 +0100
|
|
@@ -16,7 +16,7 @@
|
|
|
|
OPT_ASM_SOURCES = @OPT_ASM_SOURCES@
|
|
|
|
-SUBDIRS = tools testsuite examples
|
|
+SUBDIRS = tools
|
|
|
|
include config.make
|
|
|