5f1fa660ea
Status of the patches: - libffi-001-Fix-installation-location-of-libffi.patch, preserved. - libffi-002-Fix-use-of-compact-eh-frames-on-MIPS.patch, preserved - libffi-arc-01-Add-ARC-support.patch, removed, ARC support was merged upstream as of commit b082e15091961373c03d10ed0251f619ebb6ed76. - libffi-arc-02-Rebuild-for-ARC-additions.patch, removed, this patch was merged upstream as of commit 0f8690a84c874ec09a090c8c6adfb93c594acac6. - libffi-003-fix-typo.patch, added, reported on the upstream mailing list as being necessary, will be part of the next 3.1.1 release. - libffi-004-Add-missing-GNU-stack-markings-in-win32.S.patch, same status as patch 003. - libffi-005-Fix-paths-in-libffi.pc.in.patch, same status as patch 003. The 3.1 release adds support for a number of architectures: ARC support, ppc64le support, NIOS II support. See https://sourceware.org/ml/libffi-announce/2014/msg00000.html for details. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
47 lines
1.4 KiB
Diff
47 lines
1.4 KiB
Diff
From ad0d1d239afc7ad09203847793dcc020856d1035 Mon Sep 17 00:00:00 2001
|
|
From: Samuli Suominen <ssuominen@gentoo.org>
|
|
Date: Thu, 12 Jun 2014 06:30:21 -0400
|
|
Subject: [PATCH 09/10] Fix paths in libffi.pc.in
|
|
|
|
This patch was borrowed from upstream, commit
|
|
ad0d1d239afc7ad09203847793dcc020856d1035, and will be part of the next
|
|
3.1.1 release.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
configure.ac | 10 +++++-----
|
|
1 file changed, 5 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 4f7fe3f..bbc1a9d 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -590,11 +590,11 @@ AC_ARG_ENABLE(purify-safety,
|
|
if test "x$GCC" = "xyes"; then
|
|
if test -n "$with_cross_host" &&
|
|
test x"$with_cross_host" != x"no"; then
|
|
- toolexecdir='$(exec_prefix)/$(target_alias)'
|
|
- toolexeclibdir='$(toolexecdir)/lib'
|
|
+ toolexecdir="${exec_prefix}"/'$(target_alias)'
|
|
+ toolexeclibdir="${toolexecdir}"/lib
|
|
else
|
|
- toolexecdir='$(libdir)/gcc-lib/$(target_alias)'
|
|
- toolexeclibdir='$(libdir)'
|
|
+ toolexecdir="${libdir}"/gcc-lib/'$(target_alias)'
|
|
+ toolexeclibdir="${libdir}"
|
|
fi
|
|
multi_os_directory=`$CC $CFLAGS -print-multi-os-directory`
|
|
case $multi_os_directory in
|
|
@@ -603,7 +603,7 @@ if test "x$GCC" = "xyes"; then
|
|
esac
|
|
AC_SUBST(toolexecdir)
|
|
else
|
|
- toolexeclibdir='$(libdir)'
|
|
+ toolexeclibdir="${libdir}"
|
|
fi
|
|
AC_SUBST(toolexeclibdir)
|
|
|
|
--
|
|
2.0.0
|
|
|