a657cf77ea
Closes #293. [peter: bump to 3.3.4] Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
42 lines
1.1 KiB
Diff
42 lines
1.1 KiB
Diff
--- a/source/configure.in 2009-04-01 13:48:54.000000000 +0200
|
|
+++ b/source/configure.in 2009-04-20 13:08:42.000000000 +0200
|
|
@@ -1219,38 +1219,6 @@
|
|
AC_DEFINE(HAVE_PRCTL, 1, [Whether prctl is available]),[])
|
|
|
|
#
|
|
-#
|
|
-#
|
|
-case "$host_os" in
|
|
- *linux*)
|
|
- # glibc <= 2.3.2 has a broken getgrouplist
|
|
- AC_TRY_RUN([
|
|
-#include <unistd.h>
|
|
-#include <sys/utsname.h>
|
|
-main() {
|
|
- /* glibc up to 2.3 has a broken getgrouplist */
|
|
-#if defined(__GLIBC__) && defined(__GLIBC_MINOR__)
|
|
- int libc_major = __GLIBC__;
|
|
- int libc_minor = __GLIBC_MINOR__;
|
|
-
|
|
- if (libc_major < 2)
|
|
- exit(1);
|
|
- if ((libc_major == 2) && (libc_minor <= 3))
|
|
- exit(1);
|
|
-#endif
|
|
- exit(0);
|
|
-}
|
|
-], [linux_getgrouplist_ok=yes], [linux_getgrouplist_ok=no])
|
|
- if test x"$linux_getgrouplist_ok" = x"yes"; then
|
|
- AC_DEFINE(HAVE_GETGROUPLIST, 1, [Have good getgrouplist])
|
|
- fi
|
|
- ;;
|
|
- *)
|
|
- AC_CHECK_FUNCS(getgrouplist)
|
|
- ;;
|
|
-esac
|
|
-
|
|
-#
|
|
# stat64 family may need <sys/stat.h> on some systems, notably ReliantUNIX
|
|
#
|
|
|