25b1fc2898
- Remove 0013-Add-an-option-to-disable-installation-of-test-module.patch as it is now upstreamed. - Refactor and rename all other patches as necessary. Signed-off-by: Adam Duskett <aduskett@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
31 lines
919 B
Diff
31 lines
919 B
Diff
From 90ed5c692b8b5596ca0b3ae1436276c8181251d8 Mon Sep 17 00:00:00 2001
|
|
From: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
|
|
Date: Wed, 22 Feb 2017 17:55:59 -0800
|
|
Subject: [PATCH] Add an option to disable openssl support.
|
|
|
|
Signed-off-by: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
|
|
---
|
|
configure.ac | 6 ++++++
|
|
1 file changed, 6 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 08c148c..a81a24c 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -3421,6 +3421,12 @@ AC_ARG_ENABLE(unicodedata,
|
|
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} unicodedata"
|
|
fi])
|
|
|
|
+AC_ARG_ENABLE(openssl,
|
|
+ AS_HELP_STRING([--disable-openssl], [disable openssl support]),
|
|
+ [ if test "$enableval" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} ssl _ssl _hashlib"
|
|
+ fi])
|
|
+
|
|
AC_SUBST(TK)
|
|
AC_ARG_ENABLE(tk,
|
|
AS_HELP_STRING([--disable-tk], [disable tk]),
|
|
--
|
|
2.30.2
|
|
|