f1c092da8b
Some of the python2 patches were left behind when doing the python3 package. This was because the python build system can now autodetect what packages can be built in the system. However, some of these patches are actually useful to reduce drastically the size of the interpreter. This patch ports the relevant patches to the python3 package, and adds a new patch to remove the idle3 IDE as well from the interpreter. Fixes #5696 Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
70 lines
1.8 KiB
Diff
70 lines
1.8 KiB
Diff
Add an option to disable the tk module
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
|
|
---
|
|
Makefile.pre.in | 14 +++++++++++---
|
|
configure.ac | 9 +++++++++
|
|
2 files changed, 20 insertions(+), 3 deletions(-)
|
|
|
|
Index: cpython/Makefile.pre.in
|
|
===================================================================
|
|
--- cpython.orig/Makefile.pre.in
|
|
+++ cpython/Makefile.pre.in
|
|
@@ -980,7 +980,7 @@
|
|
EXTRAPLATDIR= @EXTRAPLATDIR@
|
|
MACHDEPS= $(PLATDIR) $(EXTRAPLATDIR)
|
|
XMLLIBSUBDIRS= xml xml/dom xml/etree xml/parsers xml/sax
|
|
-LIBSUBDIRS= tkinter \
|
|
+LIBSUBDIRS= \
|
|
site-packages \
|
|
collections concurrent concurrent/futures encodings \
|
|
email email/mime \
|
|
@@ -996,8 +996,7 @@
|
|
curses $(MACHDEPS)
|
|
|
|
ifeq (@TEST_MODULES@,yes)
|
|
-LIBSUBDIRS += tkinter/test tkinter/test/test_tkinter \
|
|
- tkinter/test/test_ttk test \
|
|
+LIBSUBDIRS += test \
|
|
test/capath test/data \
|
|
test/cjkencodings test/decimaltestdata test/xmltestdata \
|
|
test/subprocessdata test/sndhdrdata \
|
|
@@ -1053,6 +1052,15 @@
|
|
endif
|
|
endif
|
|
|
|
+ifeq (@TK@,yes)
|
|
+LIBSUBDIRS += tkinter
|
|
+ifeq (@TEST_MODULES@,yes)
|
|
+LIBSUBDIRS += \
|
|
+ tkinter/test tkinter/test/test_tkinter \
|
|
+ tkinter/test/test_ttk
|
|
+endif
|
|
+endif
|
|
+
|
|
libinstall: build_all $(srcdir)/Lib/$(PLATDIR) $(srcdir)/Modules/xxmodule.c
|
|
@for i in $(SCRIPTDIR) $(LIBDEST); \
|
|
do \
|
|
Index: cpython/configure.ac
|
|
===================================================================
|
|
--- cpython.orig/configure.ac
|
|
+++ cpython/configure.ac
|
|
@@ -2457,6 +2457,15 @@
|
|
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
|
|
fi
|
|
|
|
+AC_SUBST(TK)
|
|
+AC_ARG_ENABLE(tk,
|
|
+ AS_HELP_STRING([--disable-tk], [disable tk]),
|
|
+ [ TK="${enableval}" ], [ TK=yes ])
|
|
+
|
|
+if test "$TK" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _tkinter"
|
|
+fi
|
|
+
|
|
AC_SUBST(PYDOC)
|
|
|
|
AC_ARG_ENABLE(pydoc,
|