kumquat-buildroot/package/tinyalsa/0001-disable-doxygen-usage.patch
Maxime Hadjinlian ab70598952 tinyalsa: bump version to 1.0.2
tinyalsa has started doing release, so we will use it.

With this release, both our patches were applied mainline:
    - 0001-tinypcminfo-make-function-pcm_get_format_name-static.patch [1]
    - 0002-asound.h-include-time.h-to-get-struct-timespec-proto.patch [2]

The Makefile has changed a lot, so we take advantage of that to simplify
our package.

1. 7d204edfe8
2. c8333f8c7a

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
[Thomas: add patch to remove doxygen usage.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2016-11-02 23:23:11 +01:00

33 lines
716 B
Diff

Disable doxygen usage
In order to avoid a dependency on doxygen on the build machine, this
patch adjusts the main Makefile to not build and install the
documentation.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/Makefile
===================================================================
--- a/Makefile
+++ b/Makefile
@@ -13,13 +13,11 @@
all:
$(MAKE) -C src
$(MAKE) -C utils
- $(MAKE) -C doxygen
.PHONY: clean
clean:
$(MAKE) -C src clean
$(MAKE) -C utils clean
- $(MAKE) -C doxygen clean
.PHONY: install
install:
@@ -27,5 +25,3 @@
cp -Ru include/tinyalsa $(DESTDIR)$(INCDIR)/
$(MAKE) -C src install
$(MAKE) -C utils install
- $(MAKE) -C doxygen install
-