794ae61a15
- Remove 0001-argp-support.patch since it's already included upstream: https://git.fedorahosted.org/cgit/elfutils.git/commit/?id=1ab3c2befeedf5bd891cfbe17cfef79c06e5079a - Tweak patches for this new version: - 0002-disable-progs.patch - 0003-fts.patch - 0004-disable-po.patch - 0005-really-make-werror-conditional-to-build-werror.patch - Remove 0007-Allow-disabling-symbol-versioning-at-configure-t since it's already included upstream: https://git.fedorahosted.org/cgit/elfutils.git/commit/?id=bafacacaf7659a4933604662daba26a480b29a8d - Remove portability patch since it's no longer needed. I have asked Mark Wielaard regarding this topic given the portability patch looks been discontinued since 0.163 and he replied the following: - "I believe it is no longer needed. At least not on any platform I am actively maintaining. See also this discussion from last year: https://lists.fedorahosted.org/pipermail/elfutils-devel/2015-May/004825.html" - Add zlib dependency since it's now mandatory: configure: error: zlib not found but is required Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
51 lines
1.8 KiB
Diff
51 lines
1.8 KiB
Diff
Add a --{enable,disable}-progs configure option
|
|
|
|
Add a --{enable,disable}-progs configuration option to elfutils. This
|
|
allows to selectively disable the compilation of the elfutils programs
|
|
(in which case only the libraries are built and installed). This is
|
|
useful because the programs are often not needed, and also because
|
|
building the programs against uClibc causes several issues (lack of
|
|
obstack_printf() in uClibc for example).
|
|
|
|
Based on the former patch by Thomas Petazzoni.
|
|
|
|
[Vincent: tweak patch for 0.166]
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
|
|
|
diff -rup a/configure.ac b/configure.ac
|
|
--- a/configure.ac 2016-03-31 09:48:08.000000000 +0100
|
|
+++ b/configure.ac 2016-06-17 14:47:03.561704498 +0100
|
|
@@ -253,6 +253,12 @@ AC_SUBST([LIBEBL_SUBDIR])
|
|
AC_DEFINE_UNQUOTED(LIBEBL_SUBDIR, "$LIBEBL_SUBDIR")
|
|
AH_TEMPLATE([LIBEBL_SUBDIR], [$libdir subdirectory containing libebl modules.])
|
|
|
|
+AC_ARG_ENABLE([progs],
|
|
+ AS_HELP_STRING([--enable-progs], [enable progs]),
|
|
+ enable_progs=$enableval,
|
|
+ enable_progs=yes)
|
|
+AM_CONDITIONAL(ENABLE_PROGS, test "$enable_progs" = yes)
|
|
+
|
|
dnl zlib is mandatory.
|
|
save_LIBS="$LIBS"
|
|
LIBS=
|
|
diff -rup a/Makefile.am b/Makefile.am
|
|
--- a/Makefile.am 2016-01-12 12:49:19.000000000 +0000
|
|
+++ b/Makefile.am 2016-06-17 14:48:02.585861468 +0100
|
|
@@ -26,9 +26,13 @@ AM_MAKEFLAGS = --no-print-directory
|
|
|
|
pkginclude_HEADERS = version.h
|
|
|
|
+if ENABLE_PROGS
|
|
+PROGS_SUBDIR = src
|
|
+endif
|
|
+
|
|
# Add doc back when we have some real content.
|
|
SUBDIRS = config m4 lib libelf libebl libdwelf libdwfl libdw libcpu libasm \
|
|
- backends src po tests
|
|
+ backends $(PROGS_SUBDIR) po tests
|
|
|
|
EXTRA_DIST = elfutils.spec GPG-KEY NOTES CONTRIBUTING \
|
|
COPYING COPYING-GPLV2 COPYING-LGPLV3
|