c8ed115508
* Adapt all patches. * Use the new configure option enable-system-deps even though there is still a patch needed to correct includes. * Disable graphics to not depends on X libraries. Disable also mod_avatar from the default loaded modules, since this module requires graphics enabled. Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
44 lines
930 B
Diff
44 lines
930 B
Diff
From 21d1f05a8882657c151397d0e4723535402f1757 Mon Sep 17 00:00:00 2001
|
|
From: Philipp Huebner <debalance@debian.org>
|
|
Date: Wed, 20 Jan 2016 10:22:57 -0500
|
|
Subject: [PATCH] remove make targets for deps
|
|
|
|
Without this patch, dependencies would be downloaded and compiled
|
|
using rebar at build time.
|
|
|
|
Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
|
|
|
|
diff --git a/Makefile.in b/Makefile.in
|
|
index df2abfdc..8c8fd714 100644
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -86,27 +86,11 @@ else
|
|
INIT_USER=$(INSTALLUSER)
|
|
endif
|
|
|
|
-all: deps src
|
|
+all: src
|
|
|
|
-deps: deps/.got
|
|
-
|
|
-deps/.got:
|
|
- rm -rf deps/.got
|
|
- rm -rf deps/.built
|
|
- mkdir -p deps
|
|
- $(REBAR) get-deps && :> deps/.got
|
|
-
|
|
-deps/.built: deps/.got
|
|
- $(REBAR) compile && :> deps/.built
|
|
-
|
|
-src: deps/.built
|
|
+src:
|
|
$(REBAR) skip_deps=true compile
|
|
|
|
-update:
|
|
- rm -rf deps/.got
|
|
- rm -rf deps/.built
|
|
- $(REBAR) update-deps && :> deps/.got
|
|
-
|
|
xref: all
|
|
$(REBAR) skip_deps=true xref
|