2620a1ac2d
This version of libftdi can coexists beside the 0.x version. Signed-off-by: Daniel Sangue <daniel.sangue@sangue.ch> [Samuel Martin: - libftdi1.mk: bump to version 1.2 and add hash - cleanup uneeded libusb-compat stuff - Config.in: add comment when ftdipp1 deps are not met - fix typos in variable names and legit CMake options for *_CONF_OPTS - add support for python bindings and ftdi_eeprom - fix static build - fix build with toolchain w/o C++ support ] Signed-off-by: Samuel Martin <s.martin49@gmail.com> [Thomas: - reorder Config.in option properties: first the "bool" property, then the "selects", then the "depends on". - remove "thread" dependency from the libftdipp1 comment since the whole package can anyway not be selected if there's no thread support. - fix a big mistake in the .mk file: $(if BR2_PACKAGE_PYTHON,python,python3) replaced by: $(if $(BR2_PACKAGE_PYTHON),python,python3) - add license information.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
97 lines
3.6 KiB
Diff
97 lines
3.6 KiB
Diff
From 7e57ff280b55b45e74329b9988279e8831d32eab Mon Sep 17 00:00:00 2001
|
|
From: Samuel Martin <s.martin49@gmail.com>
|
|
Date: Sun, 25 Jan 2015 09:45:04 +0100
|
|
Subject: [PATCH 1/2] cmake: use the standard CMake flag to drive the shared
|
|
object build
|
|
|
|
Remove the STATICLIBS CMake option (and the code handling it) and let
|
|
the standard CMake flags drive the shared object build.
|
|
|
|
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
---
|
|
CMakeLists.txt | 2 --
|
|
ftdipp/CMakeLists.txt | 15 +--------------
|
|
src/CMakeLists.txt | 13 +------------
|
|
3 files changed, 2 insertions(+), 28 deletions(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 74f80f4..0ba0b08 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -46,8 +46,6 @@ set(CPACK_COMPONENT_SHAREDLIBS_GROUP "Development")
|
|
set(CPACK_COMPONENT_STATICLIBS_GROUP "Development")
|
|
set(CPACK_COMPONENT_HEADERS_GROUP "Development")
|
|
|
|
-option ( STATICLIBS "Build static libraries" ON )
|
|
-
|
|
# guess LIB_SUFFIX, don't take debian multiarch into account
|
|
if ( NOT DEFINED LIB_SUFFIX )
|
|
if( CMAKE_SYSTEM_NAME MATCHES "Linux"
|
|
diff --git a/ftdipp/CMakeLists.txt b/ftdipp/CMakeLists.txt
|
|
index 7500211..27e7884 100644
|
|
--- a/ftdipp/CMakeLists.txt
|
|
+++ b/ftdipp/CMakeLists.txt
|
|
@@ -23,8 +23,7 @@ if (FTDIPP)
|
|
set(FTDI_BUILD_CPP True PARENT_SCOPE)
|
|
message(STATUS "Building libftdi1++")
|
|
|
|
- # Shared library
|
|
- add_library(ftdipp1 SHARED ${cpp_sources})
|
|
+ add_library(ftdipp1 ${cpp_sources})
|
|
|
|
math(EXPR VERSION_FIXUP "${MAJOR_VERSION} + 1") # Compatiblity with previous releases
|
|
set_target_properties(ftdipp1 PROPERTIES VERSION ${VERSION_FIXUP}.${MINOR_VERSION}.0 SOVERSION 2)
|
|
@@ -41,18 +40,6 @@ if (FTDIPP)
|
|
LIBRARY DESTINATION lib${LIB_SUFFIX}
|
|
ARCHIVE DESTINATION lib${LIB_SUFFIX}
|
|
)
|
|
-
|
|
- # Static library
|
|
- if ( STATICLIBS )
|
|
- add_library(ftdipp1-static STATIC ${cpp_sources})
|
|
- set_target_properties(ftdipp1-static PROPERTIES OUTPUT_NAME "ftdipp1")
|
|
- set_target_properties(ftdipp1-static PROPERTIES CLEAN_DIRECT_OUTPUT 1)
|
|
-
|
|
- install ( TARGETS ftdipp1-static
|
|
- ARCHIVE DESTINATION lib${LIB_SUFFIX}
|
|
- COMPONENT staticlibs
|
|
- )
|
|
- endif ()
|
|
|
|
install ( FILES ${cpp_headers}
|
|
DESTINATION include/${PROJECT_NAME}
|
|
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
|
|
index 9fd86a6..501d4a8 100644
|
|
--- a/src/CMakeLists.txt
|
|
+++ b/src/CMakeLists.txt
|
|
@@ -21,7 +21,7 @@ configure_file(ftdi_version_i.h.in "${CMAKE_CURRENT_BINARY_DIR}/ftdi_version_i.h
|
|
set(c_sources ${CMAKE_CURRENT_SOURCE_DIR}/ftdi.c ${CMAKE_CURRENT_SOURCE_DIR}/ftdi_stream.c CACHE INTERNAL "List of c sources" )
|
|
set(c_headers ${CMAKE_CURRENT_SOURCE_DIR}/ftdi.h CACHE INTERNAL "List of c headers" )
|
|
|
|
-add_library(ftdi1 SHARED ${c_sources})
|
|
+add_library(ftdi1 ${c_sources})
|
|
|
|
math(EXPR VERSION_FIXUP "${MAJOR_VERSION} + 1") # Compatiblity with previous releases
|
|
set_target_properties(ftdi1 PROPERTIES VERSION ${VERSION_FIXUP}.${MINOR_VERSION}.0 SOVERSION 2)
|
|
@@ -38,17 +38,6 @@ install ( TARGETS ftdi1
|
|
ARCHIVE DESTINATION lib${LIB_SUFFIX}
|
|
)
|
|
|
|
-if ( STATICLIBS )
|
|
- add_library(ftdi1-static STATIC ${c_sources})
|
|
- target_link_libraries(ftdi1-static ${LIBUSB_LIBRARIES})
|
|
- set_target_properties(ftdi1-static PROPERTIES OUTPUT_NAME "ftdi1")
|
|
- set_target_properties(ftdi1-static PROPERTIES CLEAN_DIRECT_OUTPUT 1)
|
|
- install ( TARGETS ftdi1-static
|
|
- ARCHIVE DESTINATION lib${LIB_SUFFIX}
|
|
- COMPONENT staticlibs
|
|
- )
|
|
-endif ()
|
|
-
|
|
install ( FILES ${c_headers}
|
|
DESTINATION include/${PROJECT_NAME}
|
|
COMPONENT headers
|
|
--
|
|
2.2.2
|
|
|