7d348c671b
Fixes: - http://autobuild.buildroot.org/results/e64cdcf648764be53a3e951304bb89dc9410db23 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
45 lines
1.9 KiB
Diff
45 lines
1.9 KiB
Diff
From 6fe734c5a1d51e2d4a3c1cd4d7a61cc246faa3f2 Mon Sep 17 00:00:00 2001
|
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
Date: Sat, 20 Apr 2019 13:34:23 +0200
|
|
Subject: [PATCH] src/Makefile.am: fix ascii-xfr link with lintl
|
|
|
|
ascii-xfr needs to link with lintl if needed:
|
|
|
|
/home/dawncrow/buildroot-test/scripts/instance-0/output/host/bin/m68k-linux-gcc -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -W -Wall -Wextra -std=gnu99 -Wno-format-truncation -o ascii-xfr ascii-xfr.o ../lib/libport.a -lncurses
|
|
ascii-xfr.o: In function `stats':
|
|
ascii-xfr.c:(.text+0x4c): undefined reference to `libintl_gettext'
|
|
ascii-xfr.c:(.text+0xb2): undefined reference to `libintl_gettext'
|
|
ascii-xfr.o: In function `usage':
|
|
ascii-xfr.c:(.text+0x10e): undefined reference to `libintl_gettext'
|
|
ascii-xfr.o: In function `asend':
|
|
ascii-xfr.c:(.text+0x534): undefined reference to `libintl_gettext'
|
|
ascii-xfr.o: In function `main':
|
|
ascii-xfr.c:(.text.startup+0xc8): undefined reference to `libintl_gettext'
|
|
ascii-xfr.o:ascii-xfr.c:(.text.startup+0x1a8): more undefined references to `libintl_gettext' follow
|
|
|
|
Fixes:
|
|
- http://autobuild.buildroot.org/results/e64cdcf648764be53a3e951304bb89dc9410db23
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
[Upstream status:
|
|
https://salsa.debian.org/minicom-team/minicom/merge_requests/7]
|
|
---
|
|
src/Makefile.am | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
|
index 19b1888..ba92f71 100644
|
|
--- a/src/Makefile.am
|
|
+++ b/src/Makefile.am
|
|
@@ -29,6 +29,7 @@ confdir = @MINICOM_CONFDIR@
|
|
AM_CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/lib -DCONFDIR=\"$(confdir)\" \
|
|
-DLOCALEDIR=\"$(datadir)/locale\"
|
|
|
|
+ascii_xfr_LDADD = @LIBINTL@
|
|
minicom_LDADD = @LIBINTL@ $(LIBICONV) $(MINICOM_LIBPORT) $(LOCKDEV_LIBS)
|
|
minicom_keyserv_LDADD = @LIBINTL@ $(MINICOM_LIBPORT)
|
|
runscript_LDADD = @LIBINTL@ $(MINICOM_LIBPORT)
|
|
--
|
|
2.20.1
|
|
|