b18dca0df8
This commit removes the version selection for the busybox package. Busybox is very well maintained, and bugs are typically fixed in a timely fashion. Moreover, regressions are fairly unlikely in this very stable and well-tested tool. Therefore, there isn't a very compelling reason to have a version selection for Busybox since we don't accept such a version selection for the vast majority of other packages, unless there is a strong reason to do so. Consequently, this commit: * Removes the 1.19.4, 1.20.2 and 1.21.1 Busybox versions, patches and default configuration file. * Moves the 1.22.1 patches from package/busybox/1.22.1 to just package/busybox/ like all other packages. * Renames the default 1.22.1 configuration file to just busybox.config. * Adapts the busybox.mk makefile to encode the current version to use. * Adds appropriate options to Config.in.legacy. However, even though the BR2_BUSYBOX_VERSION_1_22_X is removed, we don't add a Config.in.legacy option for it, since it would cause a legacy warning for virtually *all* users as most people are currently using 1.22.x. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
30 lines
1.2 KiB
Diff
30 lines
1.2 KiB
Diff
From d4fec31889ad660a58dab633c511221feb66e817 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Sat, 5 Oct 2013 15:55:06 +0200
|
|
Subject: [PATCH] networking/libiproute: use <linux/if_packet.h> instead of
|
|
<net/if_packet.h>
|
|
|
|
The musl C library doesn't provide the <net/if_packet.h> since the
|
|
corresponding kernel headers <linux/if_packet.h> already provides the
|
|
necessary definitions. Replacing <net/if_packet.h> by
|
|
<linux/if_packet.h> also removes the need to include
|
|
<netpacket/packet.h>
|
|
|
|
This commit fixes the build of iplink with the musl C library.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
[Gustavo: update for busybox 1.22.0]
|
|
|
|
diff -Nura busybox-1.22.0.orig/networking/libiproute/iplink.c busybox-1.22.0/networking/libiproute/iplink.c
|
|
--- busybox-1.22.0.orig/networking/libiproute/iplink.c 2014-01-01 09:42:40.301137882 -0300
|
|
+++ busybox-1.22.0/networking/libiproute/iplink.c 2014-01-01 09:43:01.282827700 -0300
|
|
@@ -7,7 +7,7 @@
|
|
*/
|
|
#include <net/if.h>
|
|
/*#include <net/if_packet.h> - not needed? */
|
|
-#include <netpacket/packet.h>
|
|
+#include <linux/if_packet.h>
|
|
#include <netinet/if_ether.h>
|
|
|
|
#include <linux/if_vlan.h>
|