1267a234ff
Fix the following build failure raised since bump of webp to version
1.3.2 in commit c88c1d3319
:
/home/autobuild/autobuild/instance-9/output-1/host/lib/gcc/aarch64_be-buildroot-linux-uclibc/13.2.0/../../../../aarch64_be-buildroot-linux-uclibc/bin/ld: picture.o: undefined reference to symbol 'WebPMemoryWriterClear'
/home/autobuild/autobuild/instance-9/output-1/host/lib/gcc/aarch64_be-buildroot-linux-uclibc/13.2.0/../../../../aarch64_be-buildroot-linux-uclibc/bin/ld: /home/autobuild/autobuild/instance-9/output-1/host/aarch64_be-buildroot-linux-uclibc/sysroot/usr/lib64/libwebp.so.7: error adding symbols: DSO missing from command line
Fixes:
- http://autobuild.buildroot.org/results/9b859a701debeaddf1f9909e16adc6811a620576
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
27 lines
1.1 KiB
Diff
27 lines
1.1 KiB
Diff
From 40ecd71ff361442f1579089481619dd7cae90ffd Mon Sep 17 00:00:00 2001
|
|
From: Piotr Mionskowski <piotr.mionskowski@gmail.com>
|
|
Date: Sun, 9 Jul 2023 01:44:49 +0200
|
|
Subject: [PATCH] Include libwebp when WEBP is enabled
|
|
|
|
Upstream: https://github.com/Motion-Project/motion/commit/40ecd71ff361442f1579089481619dd7cae90ffd
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
---
|
|
configure.ac | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index ce588f65..ee45ac37 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -191,8 +191,8 @@ AS_IF([test "${WEBP}" = "yes" ], [
|
|
AS_IF([pkg-config libwebpmux ], [
|
|
AC_MSG_RESULT(yes)
|
|
AC_DEFINE([HAVE_WEBP], [1], [Define to 1 if WEBP is around])
|
|
- TEMP_CFLAGS="$TEMP_CFLAGS "`pkg-config --cflags libwebpmux`
|
|
- TEMP_LIBS="$TEMP_LIBS "`pkg-config --libs libwebpmux`
|
|
+ TEMP_CFLAGS="$TEMP_CFLAGS "`pkg-config --cflags libwebpmux libwebp`
|
|
+ TEMP_LIBS="$TEMP_LIBS "`pkg-config --libs libwebpmux libwebp`
|
|
],[
|
|
AC_MSG_RESULT(no)
|
|
]
|