a9a7a05f39
Firmware Test Suite (FWTS) is a test suite that performs sanity checks on firmware. It is intended to identify BIOS and ACPI errors and if appropriate it will try to explain the errors and give advice to help workaround or fix firmware bugs. libfdt (dtc) is an optional dependency as fwts checks for it during configure, but will only disable a few tests (dt_base, dt_sysinfo) if it is not available. This has been build-tested in x86, x86_64 and aarch64 and run-tested in x86_64 and aarch64 with EFI firmware. This package has been limited to x86, x86_64 and aarch64 architectures as it fails to build with linking errors related to ACPI functions when building for other architectures. As it is less likely that this will be used for the other architectures, they are disabled for now. Signed-off-by: Erico Nunes <nunes.erico@gmail.com> [Thomas: add missing depends on for the Config.in comment, specify the LGPL version in the license information.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
70 lines
2.2 KiB
Diff
70 lines
2.2 KiB
Diff
From db480b9f3e3a5c6c12e9dd04e87c8dff9381b8e7 Mon Sep 17 00:00:00 2001
|
|
From: Erico Nunes <nunes.erico@gmail.com>
|
|
Date: Fri, 12 Aug 2016 23:11:56 +0200
|
|
Subject: [PATCH] fwts: do not use -Werror
|
|
|
|
Warnings come and go with various compiler versions, so using -Werror is
|
|
prone to cause build failures with various compiler versions, especially
|
|
newer versions that introduce new warnings.
|
|
|
|
Remove use of -Werror.
|
|
|
|
Signed-off-by: Erico Nunes <nunes.erico@gmail.com>
|
|
---
|
|
configure.ac | 2 +-
|
|
src/Makefile.am | 2 +-
|
|
src/lib/src/Makefile.am | 2 +-
|
|
src/utilities/Makefile.am | 2 +-
|
|
4 files changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index e3e7512..64034fa 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1,5 +1,5 @@
|
|
AC_INIT([fwts],[0.1],[fwts-devel@lists.ubuntu.com])
|
|
- AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects])
|
|
+ AM_INIT_AUTOMAKE([-Wall foreign subdir-objects])
|
|
m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
|
|
AC_CANONICAL_HOST
|
|
AC_CONFIG_MACRO_DIR([m4])
|
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
|
index bc23e8d..599765d 100644
|
|
--- a/src/Makefile.am
|
|
+++ b/src/Makefile.am
|
|
@@ -14,7 +14,7 @@ AM_CPPFLAGS = \
|
|
`pkg-config --silence-errors --cflags json` \
|
|
`pkg-config --silence-errors --cflags json-c` \
|
|
-pthread `pkg-config --cflags glib-2.0 gio-2.0` \
|
|
- -Wall -Werror -Wextra
|
|
+ -Wall -Wextra
|
|
|
|
bin_PROGRAMS = fwts
|
|
|
|
diff --git a/src/lib/src/Makefile.am b/src/lib/src/Makefile.am
|
|
index 1b8fd74..163c9ae 100644
|
|
--- a/src/lib/src/Makefile.am
|
|
+++ b/src/lib/src/Makefile.am
|
|
@@ -6,7 +6,7 @@ AM_CPPFLAGS = \
|
|
`pkg-config --silence-errors --cflags json-c` \
|
|
`pkg-config --cflags glib-2.0 gio-2.0` \
|
|
-DDATAROOTDIR=\"$(datarootdir)\" \
|
|
- -Wall -Werror -Wextra
|
|
+ -Wall -Wextra
|
|
|
|
pkglib_LTLIBRARIES = libfwts.la
|
|
|
|
diff --git a/src/utilities/Makefile.am b/src/utilities/Makefile.am
|
|
index 9a47980..14997df 100644
|
|
--- a/src/utilities/Makefile.am
|
|
+++ b/src/utilities/Makefile.am
|
|
@@ -1,4 +1,4 @@
|
|
-AM_CPPFLAGS = -Wall -Werror -Wextra -DDATAROOTDIR=\"$(datarootdir)\" \
|
|
+AM_CPPFLAGS = -Wall -Wextra -DDATAROOTDIR=\"$(datarootdir)\" \
|
|
`pkg-config --silence-errors --cflags json` \
|
|
`pkg-config --silence-errors --cflags json-c`
|
|
|
|
--
|
|
2.7.4
|
|
|