kumquat-buildroot/package/gawk/0002-Fix-a-bug-with-Node_elem_new.patch
Yann E. MORIN 1227e4e720 package/gawk: don't sliently try autoreconf
Commit e6942ad11f (package/gawk: fix double free during kernel build)
backported an upstream patch, with hunks in autotools files, Makefile.am
and Makefile.in.

Such changes ususally require an explicitly autoreconf, but in this
case, Makefile.in is modified after Makefile,am, and a simple local test
did not trigger a silent autoreconf, so the patch was applied as-is.

That was a bit too optimitstic, though, and the build fails in some
situations.

Since the hunks in the autotools files are about tests, just drop those
hunks as we are not interested in running the tests.

Also drop the hunks about the changelogs while at it.

Fixes:
    http://autobuild.buildroot.org/results/068/0686697cb52d22c42ae2249db3442c008082fe72/
    http://autobuild.buildroot.org/results/754/75463639cb9cbc32108f059bd6044810a078db06/

Reported-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
2022-10-31 15:24:15 +01:00

30 lines
908 B
Diff

From baab183439ff4e0c6b77d62156d447e61fc1dcfb Mon Sep 17 00:00:00 2001
From: "Arnold D. Robbins" <arnold@skeeve.com>
Date: Wed, 14 Sep 2022 21:08:59 +0300
Subject: [PATCH] Fix a bug with Node_elem_new.
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
[james.hilliard1@gmail.com: backport from upstream commit
baab183439ff4e0c6b77d62156d447e61fc1dcfb]
[yann.morin.1998@free.fr: drop all hunks about tests and changelogs]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
---
interpret.h | 1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/interpret.h b/interpret.h
index 57d060e6..268655b2 100644
--- a/interpret.h
+++ b/interpret.h
@@ -238,6 +238,7 @@ uninitialized_scalar:
_("reference to uninitialized argument `%s'") :
_("reference to uninitialized variable `%s'"),
save_symbol->vname);
+ UPREF(m);
PUSH(m);
break;
--
2.34.1