9d274324de
Linuxconsoletools contains the inputattach utility to attach legacy serial devices to the Linux kernel input layer and joystick utilities to calibrate and test joysticks and joypads. The buildroot package adds options to build only certain tools. website: http://sf.net/projects/linuxconsole/ Signed-off-by: Koen Martens <gmc@sonologic.nl> [Thomas: minor tweaks to Config.in and .mk file.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
21 lines
695 B
Diff
21 lines
695 B
Diff
Specify sdl-config to use instead of using host sdl-config.
|
|
|
|
Signed-off-by: Koen Martens <gmc@sonologic.nl>
|
|
|
|
diff -Naur a/utils/Makefile b/utils/Makefile
|
|
--- a/utils/Makefile 2017-06-16 18:48:28.402824790 +0200
|
|
+++ b/utils/Makefile 2017-06-16 18:48:53.898696647 +0200
|
|
@@ -69,10 +69,10 @@
|
|
$(CC) $(CFLAGS) $(CPPFLAGS) -funsigned-char $^ $(LDFLAGS) -lm -o $@
|
|
|
|
ffmvforce.o: ffmvforce.c
|
|
- $(CC) $(CFLAGS) $(CPPFLAGS) -c $^ -o $@ `sdl-config --cflags`
|
|
+ $(CC) $(CFLAGS) $(CPPFLAGS) -c $^ -o $@ `${SDL_CONFIG} --cflags`
|
|
|
|
ffmvforce: ffmvforce.o
|
|
- $(CC) $^ -o $@ $(LDFLAGS) -g -lm `sdl-config --libs`
|
|
+ $(CC) $^ -o $@ $(LDFLAGS) -g -lm `${SDL_CONFIG} --libs`
|
|
|
|
axbtnmap.o: axbtnmap.c axbtnmap.h
|
|
|