6e7e733f3b
Other changes include: - Refreshing all necessary patches for 3.7.0 - Add a hash for the license file. - Python no longer has it's own internal libffi, as such, host-libffi is now required to build host-python3, and is added as a dependency. - Drop PYTHON3_LIBTOOL_PATCH = NO, since there is no longer any internal libffi copy that was causing the libtool patching process to fail. - A new core module "uuid" is now is added in the Config.in file, and relies on util-linux's uuid library. - Also, a new patch: 0030-Fix-cross-compiling-the-uuid-module.patch is required to fix compiling the uuid module, because the include directory search path for uuid.h is hardcoded to /usr/include/uuid, which causes an "unsafe for cross-compilation" error during compiling if the host pc has uuid headers installed. - 0031-Add-an-option-to-disable-uuid-module.patch is added to allow disabling the Python3 UUID module, so that when BR2_PACKAGE_PYTHON3_UUID is disabled by the UUID library is present, the uuid Python module is not built, as expected. - 0032-fix-building-on-older-distributions.patch is added to change os.replace by os.rename in the update_file.py script to fix building on older Linux distributions that have older versions of python that don't include os.replace. os.rename acts in the same way as os.replace, but is cross-platform compatible. Because Buildroot is guaranteed to be built in a POSIX environment, it is safe to change replace to rename. Tested on CentOS6 and Fedora28, All test results passed: br-arm-full [1/6]: OK br-arm-cortex-a9-glibc [2/6]: OK br-arm-cortex-m4-full [3/6]: SKIPPED br-x86-64-musl [4/6]: OK br-arm-full-static [5/6]: SKIPPED armv5-ctng-linux-gnueabi [6/6]: OK 6 builds, 2 skipped, 0 build failed, 0 legal-info failed Signed-off-by: Adam Duskett <aduskett@gmail.com> [Thomas: - remove PYTHON3_LIBTOOL_PATCH = NO - improve the solution in patch 0030-Fix-cross-compiling-the-uuid-module - add patch 0031-Add-an-option-to-disable-uuid-module] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
39 lines
1.4 KiB
Diff
39 lines
1.4 KiB
Diff
From ad4537a75c798341824ab18bd1dc622f8dc2bc3a Mon Sep 17 00:00:00 2001
|
|
From: Adam Duskett <aduskett@gmail.com>
|
|
Date: Fri, 20 Jul 2018 10:17:39 -0400
|
|
Subject: [PATCH] Fix cross compiling the uuid module
|
|
|
|
Python 3.7 has a new _uuid module, however, the include directory
|
|
search path for uuid.h is hardcoded to /usr/include/uuid, which should
|
|
not be used when cross-compiling.
|
|
|
|
To fix this, use the same solution as the one used by the NIS
|
|
detection: append "uuid" to each of the include directories in
|
|
"inc_dirs", instead of hardcoding /usr/include/uuid.
|
|
|
|
Signed-off-by: Adam Duskett <aduskett@gmail.com>
|
|
[Thomas: drop STAGING_DIR based solution, use a solution similar to
|
|
the one used for the NIS detection.]
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
|
---
|
|
setup.py | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index 1a7085c5c4..f33d0b57b8 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -1627,7 +1627,8 @@ class PyBuildExt(build_ext):
|
|
missing.append('_tkinter')
|
|
|
|
# Build the _uuid module if possible
|
|
- uuid_incs = find_file("uuid.h", inc_dirs, ["/usr/include/uuid"])
|
|
+ uuid_incs = find_file("uuid.h", inc_dirs,
|
|
+ [os.path.join(inc_dir, 'uuid') for inc_dir in inc_dirs])
|
|
if uuid_incs is not None:
|
|
if self.compiler.find_library_file(lib_dirs, 'uuid'):
|
|
uuid_libs = ['uuid']
|
|
--
|
|
2.14.4
|
|
|