59fdc58ef5
Fix the following build failure without C++ raised since the addition of
the package in commit e27ef76582
:
CMake Error at CMakeLists.txt:3 (project):
No CMAKE_CXX_COMPILER could be found.
Tell CMake where to find the compiler by setting either the environment
variable "CXX" or the CMake cache entry CMAKE_CXX_COMPILER to the full path
to the compiler, or to the compiler name if it is in the PATH.
Fixes:
- http://autobuild.buildroot.org/results/17e2d6e6d6ddf7845a37a8bbf733faf40d9faa61
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
39 lines
1.1 KiB
Diff
39 lines
1.1 KiB
Diff
From 059f67459912bba6d7f605b7c43519ff547f3a80 Mon Sep 17 00:00:00 2001
|
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
Date: Sun, 7 Aug 2022 11:34:19 +0200
|
|
Subject: [PATCH] CMakeLists.txt: fix build without C++
|
|
|
|
Fix the following build failure without C++:
|
|
|
|
CMake Error at CMakeLists.txt:3 (project):
|
|
No CMAKE_CXX_COMPILER could be found.
|
|
|
|
Tell CMake where to find the compiler by setting either the environment
|
|
variable "CXX" or the CMake cache entry CMAKE_CXX_COMPILER to the full path
|
|
to the compiler, or to the compiler name if it is in the PATH.
|
|
|
|
Fixes:
|
|
- http://autobuild.buildroot.org/results/17e2d6e6d6ddf7845a37a8bbf733faf40d9faa61
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
[Upstream status: https://github.com/raas/mbw/pull/14]
|
|
---
|
|
CMakeLists.txt | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index d3d4fcd..3b2cb3e 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -1,6 +1,6 @@
|
|
cmake_minimum_required(VERSION 3.10)
|
|
|
|
-project(mbw VERSION 1.5)
|
|
+project(mbw VERSION 1.5 LANGUAGES C)
|
|
|
|
add_executable(mbw mbw.c)
|
|
install(TARGETS mbw DESTINATION bin)
|
|
--
|
|
2.35.1
|
|
|