22b0c44eb6
Fixes: CVE-2014-8321 - gps_tracer stack overflow CVE-2014-8322 - tcp_test length parameter inconsistency CVE-2014-8323 - buddy-ng missing check in data format CVE-2014-8324 - net_get missing check for invalid values Previous CVE patch dropped since the fix is upstream. Also add hash file. Drop iw runtime dep since it's only one of many required by airmon-zc (a script) which require a ton of conditionals for just that tool. It will tell somewhat nicely if they're missing. These would be: awk - from busybox or gawk ethtool grep - from busybox or grep ip or ifconfig - from busybox, iproute2 or net-tools iw lspci - from pciutils (needs full variant) lsusb - from usbutils (needs full variant) modprobe/modinfo - from busybox or kmod uname - from busybox or coreutils [Peter: drop double -lpthread from sqlite conditional] Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
40 lines
1.1 KiB
Diff
40 lines
1.1 KiB
Diff
From 98149c7664e99cc8ce9c9b1abf2fa90d9cd68e0d Mon Sep 17 00:00:00 2001
|
|
From: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
Date: Wed, 5 Nov 2014 09:38:12 -0300
|
|
Subject: [PATCH] Makefile: use pkg-config to find libpcre, it's more
|
|
cross-compile friendly
|
|
|
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
---
|
|
Status: Upstream http://trac.aircrack-ng.org/ticket/1526
|
|
|
|
diff --git a/common.mak b/common.mak
|
|
index 6e5694b..d875708 100644
|
|
--- a/common.mak
|
|
+++ b/common.mak
|
|
@@ -39,7 +39,7 @@ PCRE = true
|
|
endif
|
|
|
|
ifeq ($(PCRE), true)
|
|
-COMMON_CFLAGS += $(shell pcre-config --cflags) -DHAVE_PCRE
|
|
+COMMON_CFLAGS += $(shell $(PKG_CONFIG) --cflags libpcre) -DHAVE_PCRE
|
|
endif
|
|
|
|
ifeq ($(OSNAME), cygwin)
|
|
diff --git a/src/Makefile b/src/Makefile
|
|
index f9217f9..14350b6 100644
|
|
--- a/src/Makefile
|
|
+++ b/src/Makefile
|
|
@@ -16,7 +16,7 @@ BINFILES = aircrack-ng$(EXE) airdecap-ng$(EXE) packetforge-ng$(EXE) \
|
|
|
|
LIBPCRE =
|
|
ifeq ($(PCRE), true)
|
|
- LIBPCRE = $(shell pcre-config --libs)
|
|
+ LIBPCRE = $(shell $(PKG_CONFIG) --libs libpcre)
|
|
endif
|
|
|
|
ifneq ($(OSNAME), cygwin) #There is yet no libpcap support for windows, so we skip the crawler
|
|
--
|
|
2.0.4
|
|
|